[SOLVED] Running Synfig after building


#1

I am using Fedora 22. The last lines that are outputed by synfig-build.sh are

[code]Reading makefiles…
Updating goal targets…
File ‘install-data-hook’ does not exist.
Must remake target ‘install-data-hook’.
make[3]: Entering directory ‘/home/comp/Source/synfig-master/synfig-studio’
/usr/bin/update-mime-database “/root/home/comp/Source/share/mime”

Note that ‘/root/home/comp/Source/share’ is not in the search path
set by the XDG_DATA_HOME and XDG_DATA_DIRS
environment variables, so applications may not
be able to find it until you set them. The
directories currently searched are:

  • /root/.local/share
  • /usr/local/share/
  • /usr/share/

Successfully remade target file ‘install-data-hook’.
make[3]: Leaving directory ‘/home/comp/Source/synfig-master/synfig-studio’
Successfully remade target file ‘install-data-am’.
make[2]: Leaving directory ‘/home/comp/Source/synfig-master/synfig-studio’
Successfully remade target file ‘install-am’.
make[1]: Leaving directory ‘/home/comp/Source/synfig-master/synfig-studio’
Successfully remade target file ‘install-recursive’.
Must remake target ‘install’.
Successfully remade target file ‘install’[/code]

Does this mean I successfully built the program? How do I run it from here?


#2

It depends on what was the usage of the script. If you did a package build you should have a message telling that the package is ready.
If you did just a build of master branch, then you have to go to the bin folder of the synfig-build directory and run synfigstudio from there.
-G


#3

maybe you should try a pass with synfig/autobuild/fedora-crosscompile-linux.sh …


#4

Thanks, I was able to build Synfig!
Just a couple questions.
What is the CPUs number for in synfig-build.sh

#!/bin/sh CPUS=1 prefix=~/Apps/Synfig export PKG_CONFIG_PATH="$prefix/lib/pkgconfig" export PATH=$(pwd)/synfig-core/src/tool/.libs:$PATH export CXX="/usr/bin/ccache /usr/bin/g++"
Also, is there a way to test code without re-building Synfig?


#5

great!, for other users, maybe you can explain what was wrong and how you solve it.
By the way, where did you found “synfig-build.sh” ? from wiki.synfig.org/Dev:Build_Instructions ?

depens on personal config, check the ouput of : $:lscpu

??? for example, after a full build, if you do a minor change into the synfig-core code you are not forced to redo a clean build… for that, from the terminal, go to synfig/synfig-core and launch “make -jX” where X is the numbers of cpu to use … is it your question ?

Also you can setup an IDE : wiki.synfig.org/Dev:IDE_Linux


#6

When I ran synfig-build.sh, there was no bin folder/Synfig executable in the same directory as synfig-build.sh. After running synfig/autobuild/fedora-crosscompile-linux.sh and then synfig-build.sh, the bin folder showed up. I got synfig-build.sh from the post [tips]how to build synfig from git (Fedora 18)

Is it used for the number of CPUs being used while building?

It did not work. For example, I made a small change in circle.cpp, I ran make -j1 in the mod_geometry directory, modules directory and synfig-core directory; but nothing changed in the program.


#7

maybe a little test about folder presence could be added! but it sound rare that it is not created by autotconf at runtime.

yes : make manual Parallel Execution

you just need to ran make from the “synfig-core” folder (or the synfig-studio folder, or ETL , if you do change there…). Then, you need to run “make install” to install the result !!! (you can do all in one time : “make -j1 install” )


#8

Thanks, that fixed the problem.