[SOLVED] Problems with Gtk 2.18

I’ve recently upgraded to Ubuntu 9.10 and I’ve started to notice the same problem that has been occurring to latest Windows binary related to panels position. Also I’ve noticed the device input problem (Tools doesn’t work)
As far as the code versions are similar or even the linux version I’m running is newest, I can bet that the cause of the problem is the new Gtk/Gtkmm libraries. I’m currently using:
gtkmm: 2.18.2
gtk 2.18.3

I would like that anyone running those libraries and the new 0.62.00 reports here same problem with the panel configuration and the input devices.

For me the problem looks like this:

  1. Run Synfig Studio for the first time (I deleted the ‘settings’ file from the .synfig folder). It looks similar to this (I’ve moved the windows positions because I have a dual screen and the windows were placed considering the whole screen as a single one):
  2. Also I have noticed that the tools doesn’t work. Click and drag and they don’t produce any result. That is caused to that the device “USB Optical Mouse” device is set to screen. That produces even this crash when use the Draw tool:
synfigstudio: workarea.cpp:1295: bool studio::WorkArea::on_drawing_area_event(GdkEvent*): Assertion `!isnan(pressure)' failed.
  1. Also I’ve noticed that this message is on the console when I move the mouse over the canvas:
** (synfigstudio:4340): CRITICAL **: clearlooks_style_draw_box_gap: assertion `height >= -1' failed
  1. After some fiddling with the application (modifying the settings, the devices an so) I always end with a panels configuration like this or similar:
    [attachment=0]panels moved.png[/attachment]
  2. Even after a third run (after disable all the extended input devices) the mouse has stopped to work (no info for the coordinates or rgba in the Info panel and no right click response) and the rulers doesn’t follow. It looks like the work area of the canvas doesn’t respond to ANY mouse event.

I have a patch for the mouse problem but I have not idea yet for the windows settings problem. I would like to collect here the same experiences from other users and platforms at last to confirm the root of the cause and start to dig in.



I had something similar on OpenArtist distro (its Ubuntu 9.10 based). I will test and report this later.

Now testing on fedora 12 and can’t confirm that.
0. I already have devices in xorg.conf configured for my tablet.

  1. Removed ~/.synfig
  2. started synfigstudio
  3. got that screenshot:[attachment=0]screenshot1.png[/attachment]
  4. Tested mouse work or not. It worked. Some input devices are enabled, some not. Here’s ~/.synfig/settings:

pref.auto_recover_backup_interval=180000 pref.browser_command=xdg-open pref.custom_filename_prefix=Мультфильм Synfig pref.distance_system=pt pref.file_history.size=25 pref.gamma=0.454545 0.454545 0.454545 0.000000 pref.predefined_fps=Заказное количество pref.predefined_size=Заказной размер pref.preferred_fps=24.000000 pref.preferred_x_size=480 pref.preferred_y_size=270 pref.resize_imported_images=0 pref.restrict_radius_ducks=0 pref.time_format=0 pref.use_colorspace_gamma=1 dock.dialog.1.comp_selector=1 dock.dialog.1.contents=navigator - info pal_edit - tool_options history canvases - layers groups dock.dialog.1.contents_size=225 166 206 dock.dialog.1.pos=1057 31 dock.dialog.1.size=208 1173 dock.dialog.2.comp_selector=0 dock.dialog.2.contents=params children keyframes | timetrack curves meta_data dock.dialog.2.contents_size=262 dock.dialog.2.pos=0 961 dock.dialog.2.size=1045 235 input_device.A4Tech USB Optical Mouse.axes=0 input_device.A4Tech USB Optical Mouse.blend_method=0 input_device.A4Tech USB Optical Mouse.bline_width=1.0000pt input_device.A4Tech USB Optical Mouse.circle.bline_point_angle_offset=0,000000 input_device.A4Tech USB Optical Mouse.circle.fallofftype=2 input_device.A4Tech USB Optical Mouse.circle.feather=0,000000 input_device.A4Tech USB Optical Mouse.circle.id=Circle003 input_device.A4Tech USB Optical Mouse.circle.invert=0 input_device.A4Tech USB Optical Mouse.circle.layer_circle=1 input_device.A4Tech USB Optical Mouse.circle.layer_curve_gradient=0 input_device.A4Tech USB Optical Mouse.circle.layer_link_origins=1 input_device.A4Tech USB Optical Mouse.circle.layer_origins_at_center=1 input_device.A4Tech USB Optical Mouse.circle.layer_outline=0 input_device.A4Tech USB Optical Mouse.circle.layer_plant=0 input_device.A4Tech USB Optical Mouse.circle.layer_region=0 input_device.A4Tech USB Optical Mouse.circle.number_of_bline_points=4 input_device.A4Tech USB Optical Mouse.fill_color=1.000000 1.000000 1.000000 1.000000 input_device.A4Tech USB Optical Mouse.keys=0 input_device.A4Tech USB Optical Mouse.mode=screen input_device.A4Tech USB Optical Mouse.opacity=1.000000 input_device.A4Tech USB Optical Mouse.outline_color=0.000000 0.000000 0.000000 1.000000 input_device.A4Tech USB Optical Mouse.state=normal input_device.Core Pointer.axes=0 input_device.Core Pointer.blend_method=0 input_device.Core Pointer.bline_width=1.0000pt input_device.Core Pointer.fill_color=1.000000 1.000000 1.000000 1.000000 input_device.Core Pointer.keys=0 input_device.Core Pointer.mode=screen input_device.Core Pointer.opacity=1.000000 input_device.Core Pointer.outline_color=0.000000 0.000000 0.000000 1.000000 input_device.Core Pointer.state=normal input_device.Macintosh mouse button emulation.axes=0 input_device.Macintosh mouse button emulation.blend_method=0 input_device.Macintosh mouse button emulation.bline_width=1.0000pt input_device.Macintosh mouse button emulation.fill_color=1.000000 1.000000 1.000000 1.000000 input_device.Macintosh mouse button emulation.keys=0 input_device.Macintosh mouse button emulation.mode=screen input_device.Macintosh mouse button emulation.opacity=1.000000 input_device.Macintosh mouse button emulation.outline_color=0.000000 0.000000 0.000000 1.000000 input_device.Macintosh mouse button emulation.state=normal input_device.Virtual core XTEST pointer.axes=0 input_device.Virtual core XTEST pointer.blend_method=0 input_device.Virtual core XTEST pointer.bline_width=1.0000pt input_device.Virtual core XTEST pointer.fill_color=1.000000 1.000000 1.000000 1.000000 input_device.Virtual core XTEST pointer.keys=0 input_device.Virtual core XTEST pointer.mode=screen input_device.Virtual core XTEST pointer.opacity=1.000000 input_device.Virtual core XTEST pointer.outline_color=0.000000 0.000000 0.000000 1.000000 input_device.Virtual core XTEST pointer.state=normal input_device.Wacom Intuos3 9x12 cursor.axes=0 input_device.Wacom Intuos3 9x12 cursor.blend_method=0 input_device.Wacom Intuos3 9x12 cursor.bline_width=1.0000pt input_device.Wacom Intuos3 9x12 cursor.fill_color=1.000000 1.000000 1.000000 1.000000 input_device.Wacom Intuos3 9x12 cursor.keys=0 input_device.Wacom Intuos3 9x12 cursor.mode=disabled input_device.Wacom Intuos3 9x12 cursor.opacity=1.000000 input_device.Wacom Intuos3 9x12 cursor.outline_color=0.000000 0.000000 0.000000 1.000000 input_device.Wacom Intuos3 9x12 cursor.state=normal input_device.Wacom Intuos3 9x12 eraser.axes=0 input_device.Wacom Intuos3 9x12 eraser.blend_method=0 input_device.Wacom Intuos3 9x12 eraser.bline_width=1.0000pt input_device.Wacom Intuos3 9x12 eraser.fill_color=1.000000 1.000000 1.000000 1.000000 input_device.Wacom Intuos3 9x12 eraser.keys=0 input_device.Wacom Intuos3 9x12 eraser.mode=disabled input_device.Wacom Intuos3 9x12 eraser.opacity=1.000000 input_device.Wacom Intuos3 9x12 eraser.outline_color=0.000000 0.000000 0.000000 1.000000 input_device.Wacom Intuos3 9x12 eraser.state=normal input_device.Wacom Intuos3 9x12 pad.axes=0 input_device.Wacom Intuos3 9x12 pad.blend_method=0 input_device.Wacom Intuos3 9x12 pad.bline_width=1.0000pt input_device.Wacom Intuos3 9x12 pad.fill_color=1.000000 1.000000 1.000000 1.000000 input_device.Wacom Intuos3 9x12 pad.keys=0 input_device.Wacom Intuos3 9x12 pad.mode=disabled input_device.Wacom Intuos3 9x12 pad.opacity=1.000000 input_device.Wacom Intuos3 9x12 pad.outline_color=0.000000 0.000000 0.000000 1.000000 input_device.Wacom Intuos3 9x12 pad.state=draw input_device.Wacom Intuos3 9x12.axes=0 input_device.Wacom Intuos3 9x12.blend_method=0 input_device.Wacom Intuos3 9x12.bline_width=1.0000pt input_device.Wacom Intuos3 9x12.fill_color=1.000000 1.000000 1.000000 1.000000 input_device.Wacom Intuos3 9x12.keys=0 input_device.Wacom Intuos3 9x12.mode=disabled input_device.Wacom Intuos3 9x12.opacity=1.000000 input_device.Wacom Intuos3 9x12.outline_color=0.000000 0.000000 0.000000 1.000000 input_device.Wacom Intuos3 9x12.state=draw window.color.pos=0 0 window.color.size=320 230 window.color.visible=0 window.gradient.pos=0 0 window.gradient.size=350 317 window.gradient.visible=0 window.toolbox.pos=4 4 window.toolbox.size=179 363 window.toolbox.visible=1

  1. Synfigstudio version:

$ rpm -qv synfigstudio synfigstudio-0.62.00-20091012.binary.1.x86_64

  1. GTK/GTKMM versions:

[tux@localhost ~]$ rpm -qv gtk2 gtk2-2.18.7-1.fc12.x86_64
Used GTKMM library is not version installed with fedora system, it is 2.8.12 from all-in-one package.

If I plug my tablet I don’t have problems.

Well, it is a negative confirmation.

Thanks for take time to report Zelgadis!
I think that we have to fix this as soon as possible because at the end most of the people will use the distributed package which will use the latest gtk/gtkmm libraries.


I have problems with windows size positions at:

  • Ubuntu 9.10 (gtk 2.18) / Gnome / Metacity
  • Ubuntu 9.10 (gtk 2.18) / Gnome / Compiz
  • Fedora 12 (gtk 2.18) / KDE / Compiz

but I have NO such problem when I run

  • Ubuntu 9.10 (gtk 2.18) / WindowMaker
  • Fedora 12 (gtk 2.18) / KDE / KWin (native wm)
  • Fedora 12 (gtk 2.18) / Gnome / Metacity (!)
  • Fedora 12 (gtk 2.18) / Gnome / Compiz (!)
  • Fedora 11 (gtk 2.16) / Gnome / Metacity

Also, as you noticed main synfig window position is always restored fine.

Thanks for the report Zelgadis. I have a solution in mind that I’ll apply as soon as i have some time. It is just a guessing but I must try it.

I have added more test-cases to the report above.
Looks like it’s a problem of gtk 2.18 + window manager trying to be smart.

The problem is solved by Genete as of “0dca8fcc06” git revision.