[Solved] my .lst import is blank - doesn't bring mouths frm papagayo


I had a look for an answer but couldn’t find one.

I’ve tried to bring in the standard hasta.lst created by papagayo’s hasta.pgo tutotial.
I created the following .lst file

FPS 24
0 rest
3 etc
5 AI
7 etc
11 AI
13 L
15 AI
17 FV
19 AI
22 etc
27 AI
29 rest
37 rest
38 MBP
42 E
45 MBP
49 E

i put the .lst file in the same folder as the phonem images AI.jpg AI.jpg…etc etc

when i import the .lst file into the synfig project i get a new layer, i get a bounding box… but i get no images at all.

did i miss something?
i have synfig 0,64
Many thanks

Your using .jpg files? Try putting jpg under MohoSwitch1. I hope this helps =0

Thank you Eric1223,
I tried that, I also tried calling all the files with .jpg after them too…ie

1 AI.jpg … Etc,

But still no joy.

Try attached file. I have it working fine with Synfig Studio 0.64.0 Mac OSX version.
papagayo-test.zip (27.6 KB)

thank you so much. Your lst file imported without a problem using all the files in teh ZIP you attached.

I moved your .lst file into the same folder as my images…your .lst worked…

I compared the difference between my .lst and your .lst - there was very little (i had a space after FPS 24). I corrected mine… it did not work.

I changed mine manually so it was identical to yours… it did not work!

I ‘Saved as…’ my file in order to change its name to something different so that I could upload it here for you to try…

I tried the file with the new name… IT WORKED! I tried the exact same file with the other name… it did not work.

This is a mystery! However, I thank you for your time in helping me prove the it would work on my machine.

God bless.
testcsv.lst.tar.gz (205 Bytes)

The problem wasn’t on the lst file. The problem was the path to look for the lst file. Somehow the code doesn’t get properly the path of the image files to retrieve from the lst file. If the sifz and the lst file were not saved properly the path becomes into a relative way (…/…/foo/bar) although it is in fact the same folder than the sifz. Then when it tries to open the image files, something internally is screwed and the images are not found although they are in the right place.

It is not easy to find a recipe to reproduce the problem, so please if you find this issue again, please save the sifz file as sir to see the path stored and try to find a clue to the mystery.


I am having this problem with list imports appearing blank and I tried the above.

I am importing a list file for lip syncing. I have imported the Papagayo example list file and it works. I have imported a file I made with Yolo lip sync program (mouth files are re-named versions of Papagayo’s) and it works. However, the list file I made with Papagayo does not work when imported and appears blank.

I have tried to fix the problem by:

  1. renaming the list file
  2. changing the directory path to the list file
  3. checked for spaces and extra characters inside the file
  4. creating a fresh text list file and manually copying over the frame instructions

I have made sure:

  1. that the list file is in with the mouth files
  2. that the list file has the correct FPS and file format commands
  3. that the file type has been renamed properly from .dat to .lst

Can anyone tell me what is wrong with it?
I know I could use Yolo for lip syncing, but I think Papagayo would give better results.
Please see attached file.

[My setup: OS X 10.9.1 (Mavericks); Synfig Studio 0.64.1 via XQuartz 2.7.5; Papagayo 1.2 via Wineskin Winery 1.7]
synctest.zip (290 KB)

This is your problem. You’re using Windows program which generates text files with CR-LF line terminators:

I manually removed the extra CR characters in Vim for you:
papa.zip (267 Bytes)

You could use Vim or some other text editor to make the conversion yourself. It’s possible that a text editor will fix the format just by opening and saving the file with different name (like it happened to RickBrock).

Notepad++ has a feature specifically to do the conversion:

:smiley: Thank you, Yoyobuae. I wondered if there were some extra characters at play that I couldn’t see.

Failure: I tried Notepad++ via Wineskin (because there isn’t a version for Mac) and the EOL Conversion didn’t work - or rather it might have worked but I think Wineskin again inserted a carriage return when I saved the file.

Success: I tried opening the file with Vim and then just saving it, and it worked.

Failure: I tried opening the file with TextEdit again and then saving, bit it didn’t work.

Success: Since the file simply required re-saving with a OS X native application other than TextEdit, I decided to try with AppleScript Editor and it worked.

This is what I did:

  1. change Papagayo’s exported file’s name extension in Get Info from .dat to .txt ( > Use .txt )
  2. open the file with AppleScript Editor (ignore dictionary warning)
  3. File > Save > Save As (read only warning) > rename file & choose File Format: Text > Save (ignore syntax warning)
  4. change the new file’s name extension in Get Info from .applescript to .lst ( > Use .lst )

:arrow_right: I hope Papagayo make a version that works for Mavericks, otherwise it is a long process. Thankfully tweaks can be made in TextEdit after the file has been created.

FlamingNuisance, welcome to the forum…

Just to signal that i haved added a simple note in wiki/doc:listimporter about lstimporter problems.

Ok so if I am making an lst file from scratch, what type of linebreaks is it supposed to have? Is it os dependent? I’m not seeing a clear result here.

from wiki.synfig.org/Doc:ListImporter and this thread earlier … does that solved ?