(SOLVED) Installation Bug - Mac

I am on a macbook pro: 64 bit , 10.7.5 up to date, and have the newest version of xquartz. I have tried to install synfig a couple times using the dmg package but when i try to open synfig it says synfig can not be opened due to a problem. It suggests I contact the developer to see if it works with my operating system. As far as I know it should work with 10.7.5. Any ideas on a solution? I’ve tried the basics: restarting, different links, etc. I don’t know about coding or anything like that.

here is a screenshot of the problem

crash report:
Process: synfigstudio [3712]
Path: /Volumes/VOLUME/SynfigStudio.app/Contents/MacOS/SynfigStudio
Identifier: synfigstudio
Version: ??? (???)
Code Type: X86-64 (Native)
Parent Process: launchd [161]

Date/Time: 2013-06-09 20:35:07.277 -0400
OS Version: Mac OS X 10.7.5 (11G63)
Report Version: 9

Crashed Thread: 0

Exception Codes: 0x0000000000000002, 0x0000000000000000

Application Specific Information:
dyld: launch, loading dependent libraries

Dyld Error Message:
Library not loaded: /System/Library/Frameworks/CoreText.framework/Versions/A/CoreText
Referenced from: /tmp/*/SynfigStudio.app/Contents/Resources/lib/libharfbuzz.0.dylib
Reason: image not found

I was able to solve it. Heres how to fix it

  1. make sure your crash report says “Dyld Error Message:
    Library not loaded: /System/Library/Frameworks/CoreText.framework/Versions/A/CoreText
    Referenced from: /tmp/*/SynfigStudio.app/Contents/Resources/lib/libharfbuzz.0.dylib
    Reason: image not found”
  2. search “CoreText.framework” make sure you have the right one. It should contain “Versions/A/CoreText” drag it to the desktop and then into the frameworks folder.
  3. Authenticate with your password.

For some reason this folder was out of place. I have no idea why since I don’t usually mess around with stuff like that but i hope this helps someone.

Late but here is a thread about that.