[SOLVED] Synfig 0.64.0 and Mac OS X Lion Problem

Hello, fellow users in the Synfig Community…

Perhaps I am missing something, but I downloaded the latest release of Synfig and it will not work on Mac OS X Lion, version 10.7.5. I was wondering if this is being addressed or not, or if this is a random glitch. Or, is this mainly for the Mountain Lion release build of Mac OS X? Can anyone give me some advice on what to do here? I downloaded the 64-bit release of Synfig, by the way, if that helps. Aside from that, I am quite stymied as to why it does not work. I even went to the point of re-installing XQuartz to improve the performance. Also, I am using a late 2009 iMac with a Core i7 processor and 16 GB of RAM. Any assistance will be most appreciated. Thanks. :smiley:

Specifically, what’s the issue? It doesn’t start? Starts but crash?

Binaries were made in Mountain Lion with compatibility for Leopard so I guess it should work on Lion. I’ll give a try on a friend of mine that still working with Lion.


Hi, Genete:

The problem is it does not start. It tries to, but it crashes before it can get to the splash screen. This is what I come up with in my log:

Dyld Error Message:
Library not loaded: /System/Library/Frameworks/CoreText.framework/Versions/A/CoreText
Referenced from: /tmp/*/SynfigStudio.app/Contents/Resources/lib/libharfbuzz.0.dylib
Reason: image not found

I hope this information is helpful. If it is, what lack I yet?

Thanks. :slight_smile:

P.S.: Sorry about the repeated posts. My Internet was kind of hanging. Didn’t realise the same posts repeated over and over. I have since deleted the duplicates. Thanks again for the support. :slight_smile:

It will be difficult to fix because we don’t have a OSX Lion around at the moment. Also, it is a package issue where I don’t have knowledge. Let’s see if Zelgadis can scratch something from your message.

Cool! Thanks. I appreciate it. :smiley:

Can you verify is this path exists in your system?

CoreText framework exists in OSX since 10.6

I see the problem. The Frameworks directory does not exist at all. Strange. I did a cd on that particular folder in my System and Terminal could not find it. Hmmm… very interesting.

Correction: the Frameworks folder is in there, but not the /CoreText.framework directory. Strange.

So, as suggested from some internet threads, maybe doing a soft link form where the CoreText framework is in your system to where it is expected to be, should solve the problem. What I’m afraid is that it maybe not the only one that has the paths not correctly adjusted.

Where is CoreText in your system?

I found CoreText files, but they are for Adobe programs on my computer and for Python. I also found an empty CoreText folder in my Xcode folder. I am not very savvy with UNIX, so I used Spotlight to find what I was looking for. Maybe I am doing this incorrectly, but I cannot find a specific CoreText file for Mac OS X itself. It is possible, however unlikely, that I accidentally deleted it using another utility program. I cannot explain it any other way. Version 0.63.05 was working perfectly before this, but I do admit I had not used Synfig for a while. So, I am stymied.

Hi, Genete:

Sorry I did not respond previously, but I tried your recommendation and performed a soft link. Now, Synfig works. Thanks for the help. I really appreciate it. :smiley:

Having the same issues as the rest in this thread. The frameworks misplaced file.

I would like to fix this, but what the heck is a soft link?

Really don’t want to muck about in library files, afraid that while it may “fix” Synfig, it may break other apps.

Not to sound too snarky or rude, but it would be a great help if things that may be obvious to some would be explained/defined to us arty-types and I don’t feel that having the user go through contortions to make an app work has “solved” any issue.

Read this thread and follow its instructions.
discussions.apple.com/thread/38 … 3&tstart=0
The solution depends on what’s specifically the situation of your CoreText.framework folder located so you have to create the soft link with the indications of the post.
I’m sorry but it is not easy to create binaries for all the OSX version around when those core libraries are moved.

Thanks for the response, Genete!

However, I am not going to muck about with the console. The last time I did, it took me hours to fix things up.

The latest Development Snapshot (synfigstudio-0.64.0-20130524) works w/o any start-up issues. So I’m going to wait for that to be committed to the next release. Until then, I’ll play around with that version and see what Synfig’s all about (more or less).

Thanks again for the reply and assist. :slight_smile:

Sorry to start up a Solved thread again :confused: I’m dealing with a similar problem. I can find the Frameworks folders (I found about six of them), but the CoreText folder doesn’t seem to exist in my system at all. I’m not sure if I should risk preforming this Soft Link thing because my CoreText is not misplaced, but simply isn’t there (I think)
What should I do?

Same here for me. Downloaded today both the x86 and the i386 version, but upon startup the icon just bounces and nothing happens. (My CoreText framework is present and in place (System Library). I’m on OS X 10.9.1 (Maverick). Any help much appreciated! (This the first time I downloaded the program, so I do not have any previous working versions.)

I’ve just upgraded to Mavericks so I would test the issue.

Thanks for looking into this issue! BTW what is the difference between the x86 en i386 version?

x86 is for 64 bits operating systems. i386 is for 32 bits operating systems.
IIRC since Lion, OSX is only 64 bits, so the other is for OSX earlier than Lion.

I’m having problems even building Synfig Studio on OSX 10.9. Some core macports libraries have changed its place.