[Solved] `GOMP_4.0' not found [Ubuntu 14.04 + derivated distros related]

linux
not-synfig-related

#1

Hello,

I’m having an issue running Synfig Studio… I googled it but with no much success. Does anyone have a clue of how to solve it?

I’ve download the latest version, chmod to 777 and run…

$ ./SynfigStudio-1.2.2-18.09.14-linux64-286f1.appimage
/tmp/.mount_Hov9Ay/usr/bin/synfigstudio: /usr/lib/x86_64-linux-gnu/libgomp.so.1: version GOMP_4.0' not found (required by /tmp/.mount_Hov9Ay/usr/lib/libMagickWand-6.Q16.so.1) /tmp/.mount_Hov9Ay/usr/bin/synfigstudio: /usr/lib/x86_64-linux-gnu/libgomp.so.1: versionGOMP_4.0’ not found (required by /tmp/.mount_Hov9Ay/usr/lib/libMagickCore-6.Q16.so.1)

Usefull Info:
SO: “Linux Mint 17.3 Rosa”

$gcc -v
GCC: COLLECT_GCC=gcc
COLLECT_LTO_WRAPPER=/usr/lib/gcc/x86_64-linux-gnu/4.8/lto-wrapper
Target: x86_64-linux-gnu
Configured with: …/src/configure -v --with-pkgversion=‘Ubuntu 4.8.4-2ubuntu1~14.04.1’ --with-bugurl=file:///usr/share/doc/gcc-4.8/README.Bugs --enable-languages=c,c++,java,go,d,fortran,objc,obj-c++ --prefix=/usr --program-suffix=-4.8 --enable-shared --enable-linker-build-id --libexecdir=/usr/lib --without-included-gettext --enable-threads=posix --with-gxx-include-dir=/usr/include/c++/4.8 --libdir=/usr/lib --enable-nls --with-sysroot=/ --enable-clocale=gnu --enable-libstdcxx-debug --enable-libstdcxx-time=yes --enable-gnu-unique-object --disable-libmudflap --enable-plugin --with-system-zlib --disable-browser-plugin --enable-java-awt=gtk --enable-gtk-cairo --with-java-home=/usr/lib/jvm/java-1.5.0-gcj-4.8-amd64/jre --enable-java-home --with-jvm-root-dir=/usr/lib/jvm/java-1.5.0-gcj-4.8-amd64 --with-jvm-jar-dir=/usr/lib/jvm-exports/java-1.5.0-gcj-4.8-amd64 --with-arch-directory=amd64 --with-ecj-jar=/usr/share/java/eclipse-ecj.jar --enable-objc-gc --enable-multiarch --disable-werror --with-arch-32=i686 --with-abi=m64 --with-multilib-list=m32,m64,mx32 --with-tune=generic --enable-checking=release --build=x86_64-linux-gnu --host=x86_64-linux-gnu --target=x86_64-linux-gnu
Thread model: posix
gcc version 4.8.4 (Ubuntu 4.8.4-2ubuntu1~14.04.1)

Thank you!!!


An issue for a problem in Linux
#2

Hi,
did you try sudo apt install libgomp1 ?


#3

Hi,

Yep… it is intalled… and seems to be the version 4.x

$ dpkg-query -l|grep libgomp
ii libgomp1:amd64 4.8.4-2ubuntu1~14.04.4 amd64 GCC OpenMP (GOMP) support library


#4

Ok, I found out that it is because you have gcc 4.8 installed in your distro (based on Ubuntu 14.04).
As seen here, you need to install gcc >= 4.9 (from a ppa), you can have 4.8 in parallel if needed.
The instructions are here


#5

Yes, works fine!!! Thank you!

For future reference, I did:

sudo add-apt-repository ppa:ubuntu-toolchain-r/test
sudo apt-get update
sudo apt-get install g+±4.9
sudo ln -s /usr/bin/gcc-4.9 /usr/bin/gcc

(From: https://superuser.com/questions/772954/install-gcc-g-version-4-9-in-linux-mint )