[Solved] Different scale after export from Inkscape

Hello,

I am not sure where I should ask: here or on Inkscape forums, but here I, at least, registered :slight_smile:
So, my problem is that if I trace a bitmap work in Inkscape and then export it to Synfig as sif file, it’s somehow always bigger than initial raster work. I can, of course, group exported layer and scale it down, but it’s a clumsy solution which require me to mess with the scale parameter to make it fit the raster work.

Here’s what you can do to reproduce it:

  1. Draw a black circle and save it as png.
  2. Open it in Inkscape.
  3. Trace bitmap (Path -> Trace bitmap…)
  4. You now got a vector layer which is the same size as your raster work. Save it to sif format.
  5. In Synfig, import that sif file and png image.
  6. Now you can see a difference in sizes.

How to prevent this? I want my region layer to be the same size as raster one.

Synfig: 1.0.2
Inkscape: 0.91

Hello

I also have that problem.
I haven’t tried but:

  • In Synfig, in the preferences panel, adjust to use pixel units. There is an option to automatically resize the image to canvas

  • In Inkscape, verify your artwork doesn’t have transformation tags in the XML editor… perhaps I’m talking about something more advanced :confused:

  • For raster images: I think that Synfig recognize that all images have 72 dpi, but Inkscape exports the images by default to 90dpi, so if you have a 100x100 px at 90 dpi then in 72 dpi the image will have the size of 72/90*100 =80 px :unamused: … in theory.

Bingo! That’s the actual problem, GIMP and Synfig uses 72 DPI and Inkscape’s 90 DPI. The worst thing is that 90 DPI is hard coded in Inkscape and you can’t change it when exporting to sif format.
So here’s the solution I came up with:

  1. When you’ve traced a bitmap and have a vector layer, go to Object -> Transform… -> Scale.
  2. Choose ‘px’ type instead of ‘%’.
  3. Set ‘Width’ and ‘Height’ to the real resolution of your raster work.
  4. Click ‘Apply’ and save the work as sif file.
    Now if you import the original raster and exported vector work in Synfig they’ll fit almost perfectly.

Thanks for the directions!

could be the time to report the issue : github.com/nikitakit/svg2sif

Did you check wiki.inkscape.org/wiki/index.php … le_Changes ?

Eh, no… I am too lazy for such a great task. I have to register somewhere and write some text…

Maybe later. I have a solution and I am happy with it for now.

:smiley:
:blush:
ouch!
I think a meme is needed here.

ejm!!

I’m a little busy now… I can’t promise nothing, just a remote chance, I’ll try, I’ll try … sorry.