[Solved] Creating a Switch Group - Problems Changing the Active Layer

switch
active

#1

When I group several layers into a switch group, and then try to change the name of the active layer to the other layer in the switch group, as the gumroad tutorial tells me to, it won’t work. I can’t change the name. I imported several different heads with different expressions, and put them in a switch group. I’m trying to make my character’s mouth move by creating a switch group. Will this work if i do this in animation mode, and create waypoints? The tutorial says you can do this without being in animation mode. All i know is, it won’t let me change the name of the active layer to the other layer in my switch group.
Another problem I have had, is that when I’m on this forum, and try to read answers to similar questions, when I click on the answer to expand it and read it, nothing happens.
My main problem is with the switch group. Any help is appreciated.


#2

Sorry im not in my house now.
Are you using the Stable Version? The development one sometimes give random troubles.
Can you post some printscreens or can you attach the files to see the problem?


#3

Can you please record a video from your screen, showing how you try to change active layer? Recording a video with your phone camera will be OK. :slight_smile:


#4

Thank you for getting back to me so quickly. I can’t post video yet, since I’ve only posted a few times on this board. There’s no dropbox displayed. I’m using the stable version of Synfig Studio 1.2.2. What I’m trying to do is create a switch group with two heads making different expressions, which I will match with an audio file. The tutorial says to put the heads in a switch group, and to go to the active layer line in the bottom left-hand corner (Parameters) of Synfig, click on it, then manually rename the file with another file in your switch group. In the tutorial, they change the name from Head5 to Head1. My problem is, when I click on the active layer file in the Parameters box, and try to rename the file, it won’t let me rename it. It turns white, but I can’t change the name. It also displays the letters “Na” after “Active Layer”. In other words, my file reads “Active Layer Na Head 5” in the Parameters box. Does Na mean not active? Another problem is, that as soon as I put the two head images in a switch group, the second head image disappears, even though the box with the handles is still displayed, but no image. It doesn’t matter if I’m in animation mode or not, my second file in my switch group disappears or turns transparent. I can’t figure out why. I follow the tutorial carefully, but strange problems develop.
Any help is appreciated.


#5

You might want to try first double clicking on ‘Active Layer Name’ and then holding left click.
For me at least, a drop down menu appears where I can choose which layer I want to have active.
Maybe this method also works for you.


#6

I have tried double clicking on the active layer name, and holding left click. I get a drop down menu that lists “convert”, “interpolation”, “forbid animation”, and “export value”. When I click on any of these, it doesn’t give me the option to rename the file. And, every time I import 2 different head files, and click on both files, and put them in a Switch Group, the second head disappears from view, even though the box with the handles is still there. So my two problems at this point are, I can’t rename the files in my switch group so they will switch, and my second head file disappears from view, even though it’s still listed in the switch group. It doesn’t matter if I make the second file the active layer, it is still not visible. And I always get this “Na” after the file names in my switch group. So a head1 file will be listed as “Active Layer Na Head1 switch” in the Parameters box. I’ve spent several hours trying to figure out what’s wrong, no luck yet.


#7

That’s really odd, I only get that list when I right click on that value.
Any chance your mouse is inverted?

That the second head in your switch group disappears is intended.
After all the switch group is used to only show one layer inside it at a time.
But it only shows the Layer with the same name specified in the value of Active Layer Name. (where you should be able to double click on to change it)

What if you renamed the head1 layer inside the switch group to what is shown in the parameter box?


#8

Thanks for the reply. Actually, it looks like I didn’t understand the directions very well. When I tried to rename the file, I thought I had to use the letter keys on my keyboard, to type in the other file name in my switch group. I finally realized that it gives you the other file name(s) in your switch group to choose from, and you just click on the alternate file name in your switch group, instead of typing it in. I should have noticed that before. The tutorial goes through that part kind of fast, and I’ve noticed in all tutorials, that they do the mouse clicks so fast, it’s hard to follow. If you’re a beginner, it makes it harder to understand. After going over the tutorial a dozen times, I finally noticed that. The problem is solved, so thanks.