[SOLVED]Building error: GLXBadFBConfig


#1

Hi, i’m trying to build synfig from synfigstudio-linux-build.sh.
I’m using a fedora 23 and i have cloned the source from origin/master, but i get this error:

Making all in images
make[2]: ingresso nella directory "/home/arkimede/dev/synfig/synfig-studio/images"
mkdir 128x128
mkdir 16x16
synfig -q synfig_icon.sif -o 128x128/synfig_icon.png --time 0 -w 128 -h 128
synfig -q synfig_icon.sif -o 16x16/synfig_icon.png --time 0 -w 16 -h 16
synfig(61619) [18:50:07] informazione: rendering threads 16
synfig(61618) [18:50:07] informazione: rendering threads 16
X Error of failed request:  GLXBadFBConfig
  Major opcode of failed request:  154 (GLX)
  Minor opcode of failed request:  34 ()
  Serial number of failed request:  27
  Current serial number in output stream:  26
X Error of failed request:  GLXBadFBConfig
  Major opcode of failed request:  154 (GLX)
  Minor opcode of failed request:  34 ()
  Serial number of failed request:  27
  Current serial number in output stream:  26
Makefile:1410: set di istruzioni per l'obiettivo "128x128/synfig_icon.png" non riuscito
make[2]: *** [128x128/synfig_icon.png] Errore 1
make[2]: *** Attesa per i processi non terminati....
Makefile:1386: set di istruzioni per l'obiettivo "16x16/synfig_icon.png" non riuscito
make[2]: *** [16x16/synfig_icon.png] Errore 1
make[2]: uscita dalla directory "/home/arkimede/dev/synfig/synfig-studio/images"
Makefile:718: set di istruzioni per l'obiettivo "all-recursive" non riuscito
make[1]: *** [all-recursive] Errore 1
make[1]: uscita dalla directory "/home/arkimede/dev/synfig/synfig-studio"
Makefile:533: set di istruzioni per l'obiettivo "all" non riuscito
make: *** [all] Errore 2

How could i solve?
Thanks in advance


[Solved] Assertion 'display' failed in Fedora build
#2

Hello kinderp and welcome here …

Have a look to the dev ml … the problem has already been identified and solved.


#3

Thanks for your reply. In my source code i have already the fix:
https://github.com/synfig/synfig/commit/580eb0bee2efa4fe4540ecd2bb818a5a02009674.
This is my Layer.cpp:

841Layer::build_rendering_task(Context context)const
842{
843	rendering::Task::Handle task = build_rendering_task_vfunc(context);
844	return task ? task : rendering::Task::Handle(new rendering::TaskSurfaceEmpty());
845}

So i have copied /synfig/share directory that i have in another machine and then i have tried to launch synfigstudio but i get this error:

[arkimede@localhost gui]$ ./synfigstudio 

   synfig studio -- starting up application...

synfig(87236) [18:59:49] info: rendering threads 16
lt-synfigstudio: rendering/opengl/internal/context.cpp:162: synfig::rendering::gl::Context::Context(): asserzione "context" non riuscita.
Annullato (core dump creato)

Any idea?


#4

manually configure the renderer to software should do the job :

~/.config/synfig/settings-1.0

pref.navigator_renderer=software
[...]
pref.workarea_renderer=software

or you can install synfigstudio dev 1.1.5 and configure the renderer to legacy from the preferences.


#5

My ~/.config/synfig/ dir contains just a fifo file.
So i have created settings-1.0 adding the two lines:

[arkimede@localhost ~]$ cat .config/synfig/settings-1.0 
pref.navigator_renderer=software
pref.workarea_renderer=software

But i get the same error. Where am i wrong?

I would try it as a last chance.

Thanks for your help :slight_smile:


#6

and keep your source and other synfig related files clean. I have recently build on fedora 23 and it was not so “annoying”.


#7

First of all thank you for your patience.
I have deleted all installation’s files and restart from scratch.
I have pulled from origin master (so i think the version should be 1.1.6).
I have rebuilded using synfigstudio-linux-build.sh with “full” option from autobuild directory:

./synfigstudio-linux-build.sh full

I’ve got always the same error.
I’m currently using a Fedora 23 on VMWare

glxinfo.txt (33.3 KB)


#8

Did you have installed synfig 1.1.5 dev and set legacy render from preferences ? That’s rare… i don’t remember i did that …

, are you there ?


#9

Hi, I have same error recently, I guess the command line of “synfig” has default settings(cobra ?) which causes this problem. The build stopped at the stage of making icons and splash. But as you might know, I can use the synfig (version 0.64.x ) command installed by DNF to make all icons and splash.


#10

Ok guys some news

@d.j.a.y
i have tried to install your deb in this way:

[arkimede@localhost Scaricati]$ sudo alien -r synfigstudio_1.1.5-20160131_amd64.deb
Warning: Skipping conversion of scripts in package synfigstudio: postinst postrm
Warning: Use the --scripts parameter to include the scripts.
synfigstudio-1.1.5-20160132.x86_64.rpm generated

[arkimede@localhost Scaricati]$ sudo dnf install synfigstudio-1.1.5-20160132.x86_64.rpm
Last metadata expiration check performed 0:58:08 ago on Sun Feb 14 16:55:58 2016.
[b]Errore: nothing provides libdb-5.1.so()(64bit) needed by synfigstudio-1.1.5-20160132.x86_64[/b]
(try to add '--allowerasing' to command line to replace conflicting packages)

The version of libdb i have installed (from repo) is 5.3.28

[arkimede@localhost Scaricati]$ dnf info libdb.x86_64
Last metadata expiration check performed 2 days, 1:42:31 ago on Fri Feb 12 16:16:31 2016.
Pacchetti installati
Nome        : libdb
Arch        : x86_64
Epoch       : 0
Versione    : [b]5.3.28[/b]
Rilascio    : 13.fc23

I don’t know how to move forward in the installation. I’m blocked here :slight_smile:

@jcome
i have installed synfig 0.64 from dnf
i have modified in the Makefile( synfig/synfig-studio/images/Makefile) the SYNFIG variable
from synfig to /usr/bin/synfig to use the 0.64 version

make creates some icons but later exits with an error on jack_icon.png.
make_output.txt (76.1 KB)

The good news is now i can launch synfig-studio but i have no icons in the gui.
If you have some ideas to solve completely let me know :slight_smile:
Currently i can start to modify and build the code even without icons

Thanks to all :slight_smile:


#11

the jack_icon.sif is made in later version than 0.64.x, and has some new layer parameter used.

And I am sorry, I have just check my Fedora, it has a 1.0.x instead of 0.64.x. so it would be a workaround if you download and install 1.0.x stable version :smiley:

Regarding GLXBadFBConfig issue, I found that there is a quite similar topic :
stackoverflow.com/questions/2384 … untu-14-04


#12

download 1.0.2, install, change SYNFIG variable from synfig to /opt/synfig/synfig :slight_smile:


#13

Thanks, add solved in the topic. :wink:


#14

Oups my fault … why .deb ? … .rpm for sure !

Glad for you it’s solved !

I think you already have read the dev" doc . Do not hesitate to ask for tips about the source organization, here ; or better to the dev ml. I think what’s help me at the beginning of the source exploration was some translation in the user doc’… but, we all are not the same :slight_smile:


#15

Thanks, i’m starting to read the wiki. See you soon :slight_smile:


#16

About this error:

rendering/opengl/internal/context.cpp:162: synfig::rendering::gl::Context::Context()

I obtain it at ./synfigstudio startup when compiling with DEBUG=1 on command line before the ./synfigstudio-linux-build.sh
Without DEBUG=1 it works like a charm.
The bad part is there is no debug info :confused:

Using Fedora 23 x64 as Guest OS
in Virtualbox 5.0.20 (3D acceleration on)
with 5.0.16 additions (the last additions version generates some errors)
on Windows 8.1


#17

I was getting same kind of error but after re-configuration of all parameters it is fixed now. I hope it will help on your way!


#18

The problem has been solved in another post already, we needed to compile with --without-opengl
See wiki.synfig.org/Dev:IDE_Linux