[solved] animating a time loop layer: unable to create waypoints


#1

Hello synfig community,

I am trying to animate a time loop layer. I.e. set the duration parameter to x at one frame and then set it to y at another frame. It is my understanding that all I would have to do is:

  • enter animation mode
  • go to the desired frame
  • set the duration parameter to the desired value

and synfig would create a waypoint at that position.

This is the case if I animate normal objects (e.g. change the amount-parameter of a rectangle) but I cannot animate time loops this way. Whatever changes I apply in animation mode they are applied globally.

Nevertheless, I can edit the time loop layer that rylleman shared in [url]Time-loop: can it do this?] as I would expect

This and the fact that I started using synfig a week ago makes me feel like I am missing something. Is there a well hidden “allow animation” tickbox? I went through the forum and the wiki but it seemed I like I am the only one doing it wrong.

Thanks for helping me get started!
ben


#2

Hi!
I don’t use Time loop layer much myself but as I recall the Time Loop Layer affects everything that lays under it. In order to let it affect only one layer you have to group it with that layer. Setting duration and start time does not create any keyframes, I think.
Greetz


#3

Thanks for the quick reply! To be clear, I don’t have any troubles using the time loop with other layers. It is animating the time loop layer itself that I struggle with.

But it should, if I do it in animation mode, no?

Btw, I forgot to mention: I am using the latest stable release, synfig 1.02 on linux mint 17.2.

best
Ben


#4

Looks like a bug to me. Changing the parameters of the time loop layer should at least deliver a waypoint in animation mode. Anyone who uses the time loop layer that can confirm his?
Greetz!


#5

Exactly this. In Time Loop’s parameters locate the green guy, right-click on it and press ‘Allow Animation’. Now you’re able to animate it.


#6

That works indeed! Two thumbs up. Should it not be better if the colors of the green guy would swap? Red for stop, so no animation and green for go, and thus allow animation. Very confusing the way it is now.
Greetz!


#7

Thanks!
It wasn’t as much confusing as I always had synfig open on a 4:3 screen. :unamused: That way the parameters section was cut off after the values. I needed to scroll right in the parameters section to see that there are even more green guys.

I see how using the same symbol as in the right corner of the preview makes them self-explanatory in a way. However since I didn’t know they exist, I didn’t realize what the documentation is speaking about :unamused:

Problem solved


#8

…added a line in the wiki to clarify the use of the allow animation settings of the Time Loop Layer.
To do: add new screenshot including the ‘green guy’ - icon(s).


#9

In fact , necessary informations already was in the “How to loop” section … i have re-update the documentation here and there … feel free to continue the effort (screen shot still missing)