Smoother font in synfig on windows 7

To enable sub pixel anti-aliased font rendering in synfig on windows 7 you can add the following line to the Synfig/share/gtk-3.0/settings.ini configuration file : gtk-xft-rgba = rgb
That won’t change the font or make it bigger but it will give a more clear type font that is more readable. If you want to change to size of the font then you can raise the dpi under windows with 3-5 percent to 103 or 105 percent. Attached picture shows the changes to the font. Nice and readable. Works for me.


Thank you!!!

My eyes are killing me trying to read the font, but this helps. I hope the next release uses a stronger font type.

Can you help me,
I am running Win 8.1, I have raised the issue of the font not being clear in another post.

When I open the ini file in notepad, add the line you suggest, but when I go to save I am getting an access denied error message.

When I try to edit the file in Notepad++ I get an error message saying “Please check if this file is opened in another program”
and it wont let me save.

What am I missing?

Thanks in advance

I found a solution on the net, I needed to run Notepad++ as administrator.
I did that and managed to save the file but it hasn’t cleaned up the fonts, they are the same as before.

Changing the ini.file only leads to a minor change. You also have to create a custom DPI font scale in Windows. Don’t know if it is the same for Windows 8.1, but on Windows 7 it goes like this:


Confirmed this fix works in Windows 10. Why isn’t it the default config for Windoze builds? The terrible looking text in the UI upon installing might scare people away from the program.

Confirmed that it also works on Windows 10. Why isn’t the configuration enabled by default on Windoze builds. The menus practically being unreadable with a pixelated font leaves a bad first impression for new users.

This has been fixed in development builds, I agree it would have been a googd thing to repack the installer but anyway this will be the case in the next upcoming “official” release, which will be fixing not only the UI Font issue :wink:
You might try the dev builds:

Makes sense. Didn’t realize that the development build was so far ahead of the regular one. Thanks for the clarification and love what you all are doing! :slight_smile: