Skeleton deformation, parts not visible

Using the Skeleton deformation the image parts disappears when the deform is visible.

Deform layer boundary is covering all images. Bone Width covers images. Skeleton is Pose reset when visibly turned on. Everything should be alright…

See this:
dl.dropboxusercontent.com/u/281 … mation.sfg

Hello, David!

I’ve come up with a quick explanation video - dl.dropboxusercontent.com/u/155 … roblem.ogv
In short: The problem coming from SFG format bug. :slight_smile:

Thank you! This is not my issue however… Looks like you’ve found another bug.

I saved as a sfg just to upload the example file with images. It was originally a sifz file.
I can see in your video that it seems to work alright for you. Unfortunately it doesn’t for me…

Have a look at this recording for a demonstration.
dl.dropboxusercontent.com/u/281 … e_demo.mkv

Wow… This is really weird. And I can see you have tiled rendering, which shouldn’t happen! (We have disabled tiled rendering severa months ago). My only guess is that you have tiled rendering enabled by some environment variable… Can you please open terminal, type “env” and post output here?

Also, please specify your version of Ubuntu.

working has expected for me … (apart the # things)

(synfig 0.65dev - commit f7d3b105e848 - debian wheezy )

yes…

Ubuntu 14.04.1 LTS
env_david_150122.txt (3.41 KB)

Found it! David, please make sure to disable Cairo rendering. :slight_smile:

what the heck with cairo render this case ?

We have no plans to continue maintaining Cairo rendering engine. Instead, we will put our efforts into optimization of current software rendering and adding hardware-optimized OpenGL engine.

Hmm, I though I had… But no… [facepalm]

An embarrased thank you!

Wihoo! :slight_smile:

does it mean cairo rendering engine only, the UI part will not be affected by this decision ?

Yes, of course the UI part will not be affected by this decision. :slight_smile:

I’m having quite possibly the same problem as described above. Parts of the image are disappearing when I enable the skeleton deformation layer. I’ve checked and I don’t have Cairo rendering enabled.
Example.zip (200 KB)
synfigscreenshot.png

Hi All
same problem as David here and as far as i check ( edit–>preferences–>render) cairo is disable
ubuntu 14.04
evn shows almost same results as David env (except user name,time paper)

is there another way to disable cairo?
thanks Claudio

Hello! This is exactly expected behavior - the image is cropped by bone influence area. You need to turn off bone distortion layer, select it, enable width handles (Alt+5) and set the influence area for each bone.
Please watch the demonstration video for details - youtube.com/watch?v=M8zW1qCq8ng

I see, thanks!

I wonder, was having the influence area be the whole bone and not just the end points (where the influence area can be modified) a design choice?

According this thread, i have done some little update in wiki.synfig.org/wiki/Skeleton_Deformation_Layer and the FAQ …

Yes, it allows better flexibility. :slight_smile:

Thanks, Djay!

Hi - five years after these responses I’m having a similar problem. I created a thigh and a calf for a leg and, following the tutorial got everything connected. As soon as I linked a bone with a rectangle (leg parts) the rectangle’s disappeared. I think I changed the bone influence area (option-5 on a mac) but that didn’t help. I created the rectangles from the spline tool as I wanted the caps to be rounded like leg joints.

Also - everyone is this thread is using the term “Skeleton Deformation Layer” whereas I only have a “Skeleton Layer.” Same thing or am I missing something.

Thank you in advance.