Silly issue with shapes

I’m a new Synfig user, so I started to follow the basic animation tutorial. It starts with drawing a rectangle and a circle, both filled with different colors. I’ve found that drawing the rectangle has no outline and no fill. Also, when I use the fill tool, nothing happens. The only tool that seems to work correctly is the sketch tool. I’m running Synfig 0.61.09, compiled on Ubuntu 8.10 (Intrepid Ibex).

Welcome! :smiley:

The rectangle has not outline, it is just that, a rectangle. But no fill? Weird. Can you post a screen shot of what do you obtain exactly? Capture the whole screen with the tool box and all the panels included.

The fill tool just change the colors of the objects where you click on them. It is not really a fill tool like a raster application fill bucket. It should have a color vacuum icon.

And what about the Bline tool, does it works? The Star tool doesn’t work either? It is hard to help you with that lack of details on what ¡s the tool that fails and how does it fails. I recommend to make more specific questions instead those general ones.

I’d first like to thank you for this long-awaited software and amazing work of yours. Can’t tell you how eager I was to get my hands on something like this. Can’t wait to start playing with it. Let’s hope it gets the notoriety it deserves. \o/
Following tutorials, I seem to have installed the windows version properly. (haven’t really tried, yet, but it does run)

However, I’ve just tried installing synfig on my linux laptop, and I seem to encouter the very same problem described here. I’m brand new to synfig, and still quite a noob to linux, so I’m a bit lost.

I run Fedora c.10 (64 bits). Since I’m lazy and synfig seem not to be in fedora repos at all, I avoided this terrifying installation page by using RPM packages I found on rpmsearch. ETL, synfig and synfig studio.

Everything seems to run smoothly, and I can run synfig without any trouble. (crashed a few times, however, but I as I don’t really know what I’m doing yet… :mrgreen: )

The first really big problem comes from shapes. I can draw with the pencil tool, I can draw polygons.
But I just can’t draw any circle, polygon, nor a star.
Synfig seems to understand what I want. The layer is created, and I can see the…eeeer… “corner points” ? But I get no fill nor line. It is invisible. (I do have a a color and line width selected, and my opacity seems to be 100%, and I am in composite mode…)

Quid ?

Bline tools seems to work properly,at least as long I’m drawing. But I get and error when I try to select another tool, (when I think my shape is done.) Maybe it’s me doing it wrong, but just in case, here is the message I get :
“layer_param_connect : unknown parameter name for this layer”
(badly translated from french)
(I get the same error -and a crash- when I try to draw a shape with the “create an outline” and/or “create a region” boxes checked, but maybe that is just me messing things up :blush: )

Please help, obi wan kenobi, you’re my last hope… :neutral_face:

Oh yeah, BTW, I forgot to mention, I’m no coder, but if you need some help translating things in french (manual or so) maybe I can help (if I can find some spare time, that is…)
(thanks again)
(damned ! I just posted as guest… Once a noob, always a noob… )

Eeeeer… Hello ?
Well, I assume you have no solution, or maybe it is a silly question, or maybe this post is not in the proper thread… (my apologies if this is the case)
But I sure would appreciate even a short answer like “we don’t know really” or “this has been answered so often before” or even “stop complaining a create a bug report, you jerk”… :frowning:

Being invisible is quite sad. Nobody loves me. :confused:

Thanks for your work, anyway.

Dear Sir,

we are deeply sorry for the perceived trouble we have caused you. Please be advised that the person resposible for neglecting your basic needs has been punished appropriately and is now working from a small cabinet in the basement.

The Synfig Customer Support Administration Head Office

Thouse kind of “strange things that happens only to you” are difficult to reproduce in other places. How can we know what’s happening if we cannot reproduce it with a recipe? It doesn’t mean that the problem doesn’t exist but we cannot help you much if the recipe is not clear and reproducible.
Please don’t be annoyed by the repetition of this information but it is important to be sure what’s happening:

  1. Did you uninstall completely the bad version that Ubuntu ships?
  2. Did you installed the correct development libraries to build Synfig?
  3. Did you obtain any error message during compilation or linking?
  4. Can you provide a sample file where the corners are shown but not the fill?
  5. Have you found a step by step recipe to reproduce the crash? Please provide.

I have Ubuntu 8.10 too and haven’t any problem of that type with my built version.


Let him out ! \o/ I want no responsibility in any kind of work related oppression ! Please, at least feed him. :neutral_face:

Thanks for your time and concern.
Well, first i realize I should have opened a new thread. I am not the same person who had this same problem in the first post.
My OS is fedora 10 (64 bits) and I’ve installed Synfig from RPMs I’ve found on rpm search (yes I know, it’s bad… :blush: links above) However, the installation seemed to run fine. No error message, dependencies seemed to install fine, and the program does run.
OK. I will uninstall the rpm version and install a clean and “official” version, following the installation instruction step by step.
I’ll come back and tell you what happens.
(but this week end only. No time tomorrow)

Again, thanks for your time and work. :smiley:

Same problem here. V o.62.o2 on a dual core little Vista [arrrrrgh] box. I was running the tutorials and everything was ok to the intermediate stage on the flower tutorial. Then I could not fill the background colors with the gradient tool. I went back to the beginning tutorials to see if I missed something. At that point I couldn’t even get the color fill to work on a circle! I could make the circle [invisible] click on the transform tool and the outline would be there. I could play with the ducks, all the info would be in the params screen including COLOR OF THE SUPPOSED FILL, size, etc, but still I have an invisible circle. I returned all setting to original many times then uninstalled and installed the program again. Nothing, nothing, nothing. Madness! Please help or send me an excorcist.

Can you check the Blend Method of those invisible layers? double check that the blend method is set to Composite, that the Amount parameter’s value is greater than zero and that there is not any encapsulating Paste Canvas layer with the same blend and amount values.

In any case please upload the sample file here and let me see.


The blend method was set to ‘color.’ That did it. Thanks! This program might be too complex for a hillbilly like me. Maybe I ought to go back to the box of 8 Crayola crayons and a sheet of newsprint. :laughing: