SIF output extension to ship in Inkscape 0.49, needs testing


#21

A new stable version is now tagged. It fixes a few bugs, including a small mistake in the previous version that could affect a lot of SVG files.

The “shattered glass” bug is essentially all that remains to be fixed, unless testing turns up something else. (There’s still numerous unsupported SVG features, some of them leading to crashes, but I’m considering those outside of the scope of the converter).


#22

That last bug is fixed now… it turned out to have been a mistake on my part rather than a flaw in the algorithm.


#23

on work I use Win32.
I copied the files
synfig_fileformat.py
synfig_output.inx
synfig_output.py
synfig_prepare.inx
synfig_prepare.py
in:
D:\Programmi\Inkscape\share\extensions
but Inkscape 0.48.2 cannot see the extention, in Save as, I cannot see *.sif format.
Whats wrong?
thanks


#24

I’m surprised that this wouldn’t be working. I can’t give a definitive answer (since I don’t use Windows), but I’ll do my best to go over some possibilities.

  1. Is there a menu item in Inkscape called “Extensions>Synfig>Prepare for Export”? If there is it means that at least half of the extension loaded correctly (you can then skip ideas #2 and #3).
  2. Are there other extensions in “D:\Programmi\Inkscape\share\extensions”? (If not, then I made a mistake and posted the wrong folder name)
  3. Does the extension work if you place it in “Documents and Settings<Your User Name>\Application Data\Inkscape\extensions”? (you may need to create this folder)
  4. Is there a file called “extension-errors.log” located in either “D:\Programmi\Inkscape\share” or “Documents and Settings<Your User Name>\Application Data\Inkscape”? If there are any errors with the extension, they would be recorded in this file and I could figure out what happened.

At the moment I can’t come up with other possible problems. I hope this helps. If not, maybe someone at the Inkscape forums will have better ideas.


#25

this evening I can try on Ubuntu

no

yes, the folder is full of *.py and *.inx files

no, the locale folder is:
C:\Documents and Settings<user>\Dati applicazioni\Inkscape\extensions
but copying files there, does not work.

I also tried to create the folder:
C:\Documents and Settings<user>\Application Data\Inkscape\extensions
and copy here the files, same results.

yes, it is in:
C:\Documents and Settings<user>\Dati applicazioni\Inkscape
attached. It show many extention dependancy error, but seems nothing related to svg2sif

I will also try to post the problem on Inkscape forum.
extension-errors.log (2.07 KB)


#26

I’m completely at a loss as to why this doesn’t work. The only other possibilities I can think of is that you haven’t restarted Inkscape, or that you’re somehow running a different copy of Inkscape.

I hope that you’ll be able to sort this out.


#27

I have only one copy of inkscape installed on Win32, and every time I added files in a directory, I closed and restarted Inkscape


#28

posted:
inkscapeforum.com/viewtopic. … 129#p38129


#29

Hi nikitakit!
I’ve been playing a bit with the svg2sif extension and I just can say that it works wonderfully. It has been difficult to find any failure using the basic drawing tools and objects.
I have found two mistakes related to winding style:
When exporting objects made with the calligraphic tool or the polygon/star tool, the result doesn’t keep the winding style, selecting Even/Odd instead of Non Zero for the sif file.
I think it will be easy to fix.
Congratulations!
-G
star.svg
star.sif (13.8 KB)
star-inkscape.png
star.png


#30

You’re right, it was a very simple fix. Thanks for catching it.

A new stable version is out with that fix and a few changes related to code cleanup.


#31

$ lsb_release -a
Distributor ID: Ubuntu
Release: 11.04
Codename: natty

$ uname -a
Linux 01ato1600 2.6.38-11-generic #48-Ubuntu SMP Fri Jul 29 19:05:14 UTC 2011 i686 i686 i386 GNU/Linux

$ sudo cp -i *.py /usr/share/inkscape/extensions/
$ sudo cp -i *.inx /usr/share/inkscape/extensions/

interestingly, no new menu in Extensions, and no Save as *.sif
Here standard Ubuntu Inkscape version is 0.48.1

The “extension-errors.log” in ~/.inkscape was 2008 old.
I renamed it and now never recreates.
Anyway here attached the Ubuntu one
extension-errors.old.log (2.17 KB)


#32

That’s really strange, because that’s almost exactly the setup I’m running (Natty + Inkscape 0.48.1). On natty, the folder is “~/.config/inkscape” and not “~/.inkscape”. That’s where extension-errors.log should show up. That’s also where I have my copy of the extension installed (via symlink).


#33

oh yes, the folder is “~/.config/inkscape” and not “~/.inkscape”, I have both paths.
This is because the error log was old and never get recreated.
In .config, the log is update, get recreated on start, but do not speak about sif problems.

I also tried to copy the scripts to:
~/.config/inkscape/extensions
but same results.

I do the same on Windows copying scripts to:
C:\Documents and Settings<user>\Dati applicazioni\Inkscape\extensions
same results.

As on Linux there was an old path probably from an ancient Inkscape versions, so I scan user home on Windows, and found another Inkscape directory:
C:\Documents and Settings<user>\AppData\Roaming\Inkscape\extensions
but there is an error log dated 2009. Anyway I copied the scripts also here, same results.

Anyway I want a system installation, not a user installation. The script was tested for all users too?

Are there some file with the list of installed extensions to add svg2sif by hand?

A curiosity: in Extension menù, the new entry should appear at the top level, or in a sub entry like:
Bitmap, color, generate from tracks, images, …
How should be named exactly?

Maybe the problems are related to locale directory/settings or so (for example my Extension menù is named “Estensioni”)?


#34

Wow… as far as I can tell you’re doing everything right. I’m not an Inkscape expert so I’m just going off of what works for me in the setups that I have available.

The “Save As” option should be named: “Synfig Animation (*.sif)”
The menu option should be named “Extensions>Synfig>Prepare for Export”. That is a “Synfig” submenu in the Extensions menu.

As a shot in the dark, I tried removing localization from the .inx files. I wonder if that has any effect. (See attached - the .txt is added on because the forum doesn’t allow .inx files).

There isn’t a file that lists all extensions: instead Inkscape looks at a certain set of directories (including /usr/share/inkscape/extensions) and reads all the files in there. Do other extensions show up in Inkscape? (e.g. Extensions>Text>UPPERCASE)
synfig_output.inx.txt (790 Bytes)
synfig_prepare.inx.txt (611 Bytes)


#35

thanks, so I know what look for

yes, the ones that are distributed with Inkscape are loaded and work.
A problem I can see is that there is no documentation that explain how to install additional extentions


#36

with those two files, the new entries appear on Win32. This evening I will try on Ubuntu


#37

but I got error with both Prepare to Export menù and Save as:

File “synfig_prepare.py”, line 6

^
SyntaxError: invalid syntax

File “synfig_output.py”, line 6

^
SyntaxError: invalid syntax


#38

I looked in some other .py files installed by inkscape in extensions directory.
They look much different than synfig files.
For example I looked at:
color_desaturate.py
color_grayscale.py
they seems standard python source (anyway I’m not an expert of python),
while Synfig *.py files are html files with javascript embedded or something similar


#39

solved: I downloaded the files from page:
github.com/nikitakit/svg2sif
using Firefox 6.0.2 using right click and “save link as”.
Those method generate the wrong file with the right name.
I do not know if it is a problem of Web page mime type or so.

In any case, I downloaded it again as tar.gz or zip and worked.


#40

Good thing that’s solved. I probably should have guessed what was going on, sorry for not being able to catch that.

I need better documentation on the page to make sure something like this doesn’t happen again. (I’m actually tempted to do “Save Link As” myself every time I go to github).