Shared libraries error


#1

Firstly, thanks to those devs who put together an all-in-one package for Synfig. This is my first attempt at playing around with any animation package so the intent is very much appreciated.

I tried installing 0.63.05 on my 64-bit machine. I’m using Chakra Linux 2013.03 It’s beautiful and fast and I’m liking it a lot. When I run synfigstudio, however, I get the following message:

/home/ksa/Applications/synfigstudio-0.63.05-20120409.master.8.x86_64/bin/synfigstudio: error while loading shared libraries: libpng12.so.0: cannot open shared object file: No such file or directory

Chakra is as pure a Qt environment as you can get and I don’t have a CLUE what libpng12.so.0 is. Is the problem GTK-related?

Kaz Augustin


#2

Hi KazAugustin, welcome to the forums.

/home/ksa/Applications/synfigstudio-0.63.05-20120409.master.8.x86_64/bin/synfigstudio: error while loading shared libraries: libpng12.so.0: cannot open shared object file: No such file or directory

Are you using the universal binaries?
If so, could you run the synfigstudio executable at the top of the unpacked folder?
For more information read this issue:
synfig.org/issues/thebuggeni … issues/402

-G


#3

Hi G!

Thanks for the welcome. Yes, I used the universal binaries. And I originally ran it from the top-level directory; i.e. not /bin. No dice. Went into /bin, y’know just to be sure, and I got the error referenced in the thread you linked to above. So can confirm that my problem is not QUITE that one.

Interestingly, when I did a “whereis” on libpng, my system tells me that libpng15.so is located in /usr/lib. Note that this is libpng15 and the error msg I’m getting is about libpng12. Could we be talking about some version incompatibility issue here? Just throwin’ things out there! :wink:

Kaz!


#4

Yes, it is possible that there are conflicts with the libraries.
Please open a bug issue for that case and be patience meanwhile we fix it. Not planned in a short term, but well.

Alternatively you can compile the binaries yourself. Please wait until we release 0.64.0 (in a few hours or days) and download the tarball and do the classic “./configure && make install”

Cheers!
-G


#5

Okay, I’m in no rush. Just thought I’d do some part-time upskilling! :slight_smile:

I might try compiling the source and see what happens. If I still get the same error, I’ll open a bug issue.

Kaz!


#6

OK, looks like we have to bundle libpng into our binaries. Please open bugreport for that.


#7

I have fixed issue in the latest development snapshots - download.tuxfamily.org/synfig/packages/binaries/
Please test and report if it works fine for you.