Running finishes with errors [Windows - export ordinal too large]

Hey so I ran with mingw64 with seemingly no issue, then ran and it ended with errors:

  CXXLD    synfigstudio.exe
C:/msys64/mingw64/bin/../lib/gcc/x86_64-w64-mingw32/11.3.0/../../../../x86_64-w64-mingw32/bin/ld.exe: error: export ordinal too large: 73261
collect2.exe: error: ld returned 1 exit status
make[4]: *** [Makefile:1641: synfigstudio.exe] Error 1
make[4]: Leaving directory '/d/Documents/GitProjects/Synfig/_debug/synfig-studio/src/gui'
make[3]: *** [Makefile:4089: all-recursive] Error 1
make[3]: Leaving directory '/d/Documents/GitProjects/Synfig/_debug/synfig-studio/src/gui'
make[2]: *** [Makefile:451: all-recursive] Error 1
make[2]: Leaving directory '/d/Documents/GitProjects/Synfig/_debug/synfig-studio/src'
make[1]: *** [Makefile:693: all-recursive] Error 1
make[1]: Leaving directory '/d/Documents/GitProjects/Synfig/_debug/synfig-studio'
make: *** [Makefile:529: all] Error 2

This is the bin folder afterwards:

Any idea what’s going on here? I’m on windows 10.

1 Like

Hi and welcome here :slight_smile:
This is a known issue at the moment for Windows (see Error while building debug verision on windows. · Issue #2565 · synfig/synfig · GitHub)

By luck the final production compilation through morevna-build is ok.

Until this will be solved (if it can, it is a compiler’s limitation obviously, too many symbols, limit at 65535), you can still use a Linux virtual machine to do the development :wink:


Aight thanks, will do. I checked the issues for this, but guess I didn’t look hard enough haha whooops. I think I saw that one and just glanced through and didn’t think it was my issue

Hi! Please use for Windows build. This issue is present in autotools only.