Resetting image paths?

ok…i’m sorry, Genete :exclamation: i LIED :exclamation: i AM going to ask another question, just because i have no way of figuring this one out on my own… :frowning: i’m trying to get my ninja sifz file working in ubuntu (previously it was/is in Vista), but i ran into a slight problem… :unamused: i thought possibly creating folders in ubuntu with the same names that they were/are in Vista, and then pasting the proper files (i.e. the imported images and the sifz files) in them would allow me to be able to open up the sifz file in ubuntu, and since the image paths would be pretty much the same, i.e. the sifz file being in a folder called ‘Top secret documents’ like it is in Vista, and the images being in a folder named ‘Ninja Image Parts’, i would have no problems accessing the imported ninja images in my sifz file, and i could continue where i left off…apparently though, such is not the case :exclamation: i tried opening the sifz file, but the images weren’t in there, and its only a blank canvas, although the layers r still in there, and in their proper places… :unamused:

so my question is, can anyone help me with this problem, that is perhaps resetting the image paths, to fit the actual paths it would need in ubuntu? (i already have both the image files that i imported and was working with, along with the sifz file, successfully in ubuntu)

Thanks, and MUCH appreciation :exclamation:


Select the file name parameter (expand the width of the column by dragging is separator line)):

Double click on it (a choose file button will appear):

Status after select the file:

Click on any other parameter to apply changes:


EDIT: Post sounded too demanding…

Hi Coolname0007,
Don’t worry on ask about it if the program doesn’t do what you expect.

Be sure that:

  1. You don’t enter the file name by hand using the keyboard.
  2. You press the button “Choose File” (or something like that in English) and the Select File Dialog is opened.
  3. You select an image file in the choose file dialog and press the “Accept” button. Take account that maybe you don’t see the extension of the file and you can be choosing the Photoshop (.ps) one instead of the Portable Network Graphic one (.png). Notice how looks the last screenshot I posted. You can see there the “relative path” of the selected image (png) file to the animation file that I was creating.
  4. If above fails then try to import the image file again (in that or in another document) using Caret Menu>File>Import. It should give you the same error message if the problem is in the image file itself. If the file can be loaded then you did somethig wrong during restore path of image file .

If everything is still failing then you have to write a “detailed step by step recipe” and provide the image file you are trying to import (restore the path in this case). As you can see I cannot reproduce the same error.

Last thing: As well as you are a dual synfig user, please in future questions please provide the information about what operating system are you using and which version of synfig are you dealing with.


Thanks, Genete, for the effort, but i tried typing the filename (yes…by hand :laughing: ) again, and this time it worked…could have sworn i did the exact same thing last time, but i got a different result… :blush: as for the ‘Choose File’ button, i could find no such thing…maybe its not in my version of synfig…but thanks for trying to help :exclamation: i really appreciate it :wink: now my problem is, the kusari layer, for some reason, even though its at the top, appears to be hidden under the rightarm layer, which is below it in the layer order…and so the kusari layer is not visible :unamused: i’m in ubuntu right now, by the way, as i type this message

Hope someone knows what the problem is… :wink:

Check the “Blend Method” of the kusari image layer. It must say: “Composite”. Maybe it says “Below”?
Are you sure that the kusari layer is on top? check the Z column of the Layer list. Meybe you unitentionally changed it and now it is not ordered by Z depth but by name.

ok…i looked, Genete, and yes, the blend method was set to ‘Composite’ on the kusari layer…and also on the rightarm layer, for i checked that one too :confused: as for being sure is the kusari layer is on top, u have only to check the sifz file that i sent to u to make sure…i haven’t changed the layer order since…the kusari layer is still above the rightarm layer in the Layers panel, and as far as i can tell, both layers r still set to Z depth, although they r under the name column on the right of the Layers panel, if that’s what u were talking about…

so the kusari layer still is not visible… :unamused:

Looking forward to ur next reply,



ok…here’s a screenshot of it, so u can see for yourself :wink:

Look to the ‘kusari’ canvas layer blend method (the layer with a brown box as icon).
If it is Composite, paste here a link to the file. I cannot deduce the problem without seeing the file.

ok…the kusari inline canvas was set to composite blend method… :confused:

here’s another screenshot for u, with the kusari inline canvas selected, so u can for yourself…make sure to scroll more to the right on the webpage this time, so u can see the whole image (not saying u didn’t before…just wanted to clarify it) :wink:

ok…here’s the link :exclamation: this time i included both the sifz and the image files in the uploaded file…the image paths r also still correctly set :smiley:



I think it’s there - just at the resolution that you’re at, it only shows up as 3 pixels. Try zooming in on the canvas (the + button bottom left) to see more detail on the screen. Here’s what I see at ~700% zoom.


EDIT: My first forum, I apologize for all my dumb-looking and dumb-sounding posts. They don’t reflect what I was thinking at the time at all…