Rendering CLI, OpenSUSE11.0

I’m a beginner to synfig. I used the command line (in xterm) to render a 60 second animation in 2 minutes, using this simple command:

# synfig -o input.sifz moviefile.avi

I used Windows Media Player to watch it, and it was fine. Then I installed the latest KDE codecs YMP, so I could use SUSE to watch the avi. But my next attempt at rendering, using the same basic command, brought this:

# synfig -o input.sifz moviefile.avi synfig: warning: Unable to find module "mod_magickpp" ( cannot open shared object file: No such file or directory) I/O warning : failed to load external entity "moviefile.avi" synfig(3947) [22:50:27] error: Standard Exception: Couldn't create parsing context Unable to open moviefile.avi. Throwing out job... Nothing to do!

The warning about mod_magickpp appeared the previous time also, but the rendering still worked then.

Is it possible that the new media-playing codecs, which includes the latest ffmpeg, disables synfig from rendering properly?

Thanks in advance for any assistance,

I also tried:

#synfig -t ffmpeg -o inputfile.sifz test.avi

and got about ten minutes’ worth of messages like this:

synfig(4059) [23:18:50] warning: Broken Pipe...

Kernel: Linux i686
System: openSUSE 11.0 (i586)
CPU: 1.60GHz

synfig: 0.61.09
synfig info: Compiled on Jan 5 2009 with GCC 4.3.1 20080507 (prerelease) [gcc-4_3-branch revision 135036]
ffmpeg: version 0.5
ffmpeg info: built on Sep 2 2009, gcc: 4.3.1 20080507 (prerelease) [gcc-4_3-branch revision 135036]
libavutil 49.15.0 / 49.15.0
libavcodec 52.20.0/ 52.20.0
libavformat 52.31.0 / 52.31.0
libavdevice 52.1.0 / 52.1.0
libswscale 0.7.1 / 0.7.1
libpostproc 51.2.0 / 51.2.0

Other info:

  • I updated to the latest version of synfig between the previous successful rendering attempt and the latest.
  • The new animation imported lots of high-resolution JPGs, but still only 60 seconds.
  • Preview works fine. Am not going to attempt synfigstudio render (the previous animation took 5 hours to make a 60-second png sequence).
# synfig -o input.sifz moviefile.avi

I cannot understand that this command line worked the first time… :question:
Look the command line interface help message:

[code]$ LANG=C synfig --help


-t Specify output target (Default:unknown)
-w Set the image width (Use zero for file default)
-h Set the image height (Use zero for file default)
-s Set the diagonal size of image window (Span)
-a <1…30> Set antialias amount for parametric renderer.
-Q <0…10> Specify image quality for accelerated renderer (default=2)
-g Gamma (default=2.2)
-v Verbose Output (add more for more verbosity)
-q Quiet mode (No progress/time-remaining display)
-c Render the canvas with the given id instead of the root.
-o Specify output filename
-T <# of threads> Enable multithreaded renderer using specified # of threads
-b Print Benchmarks
–fps Set the frame rate
–time Render a single frame at
–begin-time Set the starting time
–start-time Set the starting time
–end-time Set the ending time
–dpi Set the physical resolution (dots-per-inch)
–dpi-x Set the physical X resolution (dots-per-inch)
–dpi-y Set the physical Y resolution (dots-per-inch)
–list-canvases List the exported canvases in the composition
–canvas-info Print out specified details of the root canvas
–append Append layers in to composition
–layer-info Print out layer’s description, parameter info, etc.
–layers Print out the list of available layers
–targets Print out the list of available targets
–importers Print out the list of available importers
–valuenodes Print out the list of available ValueNodes
–modules Print out the list of loaded modules
–version Print out version information
–info Print out misc build information
–license Print out license information[/code]

According to the usage syntax, the correct command line is this:

$ synfig myfile.sifz -o myfile.avi

Maybe you did that the first time and not the last time?