Recommended Hardware Requirements

I have been experimenting with Synfig to achieve the “Write-On” effect used by Vidoons (www.youtube.com/watch?v=KO_WmWV87t8 ). I have tried two different Windows XP computers and even setup a Ubuntu 32 bit configuration (admittedly on an older computer). It seems that after I have drawn about four Blines, the memory maxes out and Synfig crashes. I emailed the same file to my son’s 64 bit, 4 processor, linux laptop and it ran fine.

I have searched Synfig.org but can’t find the recommended hardware. What can you advise?

Thanks,
StanH

I don’t think that the crashes are caused due to the computer’s specifications are too old.
I’ve been running Synfig Studio in a Virtual machine with small hardware resources and it has gone fine.
Can you post here the offending file and let me try it on a virtual machine with the same requirements of your old computer?
Specifically it might be important to know what’s the Ubuntu version of the old computer because it might be a library uncompatibility.
I hope it helps.
-G

Yesterday I set-up Ubuntu 11.04 (latest 32 bit version) on a computer at home.

On the Windows computer in my office (where I am now) the attached file shows the following warnings in the Command Prompt window:

“Synfig<4104> [7:50:52] warning: WPList doesn’t exist yet
Synfig<4104> [7:50:52] warning: Advanced Outline: WPList doesn’t accept new bline”

(about 4 times)
After Synfig crashes, it shows:

“Synfig<5544> [8:02:50] error: Advanced Outline:: sync<>: Exception thrown”

and a Window Error box comes up reading:

"Glibmm-ERROR**
Unhandled exception (type std:exception) in signal handler:
What St9bad_alloc

Aborting…"

I don’t know if you can gleen anything from the above information. On the Ubuntu machine, I redid the file from scratch. I can forward that later.

(You will have to rename the RixeySketch2.png to RixeySketch.png. I renamed it since I had to reduce size to upload.)

Thanks,
StanH


Rixey3.sifz (8.54 KB)

Ok, the attached screenshot is the older computer specs (i.e. – the one being used for Ubuntu). Hopefully that is enough info. Also attached is the synfig file. My question is:
“Is the computer under-powered or is something else happening?”

Thanks,
StanH
RixeySketchSyn.jpg
RixeyWriteOn.sifz (5.07 KB)
Screenshot.jpg

File crashes for me :frowning:

Well, I guess the question is “Where do I go from here?” I don’t think the file could be much simpler. I have imported a picture to trace. I have started drawing Blines with flat width ends at position 0 in one frame and at position 0 and 1 on the subsequent frame to create a write-on effect. When I get to about the fourth Bline, the program starts crashing. I have done this over and over on two separate Windows XP machines and one Ubuntu machine. Unless I am inadvertently doing something to screw it up, there would seem to be a bug somewhere.

Do you have an example where someone has used multiple Blines to create a sketch in this manner? I believe Genete’s “U” example uses just one Bline.

I don’t know where to turn now (except to purchase Adobe Aftereffects which I can’t afford anyway).

Thanks,
StanH

The sample file crashed here on this Windows Vista computer.
Did it crash on Ubuntu 11.04? or did it work fine? I guess it crashed too.

Synfig<4104> [7:50:52] warning: WPList doesn’t exist yet Synfig<4104> [7:50:52] warning: Advanced Outline: WPList doesn’t accept new bline
Those messages are normal, they will appear every time an Advanced Outline is created. Will be removed in the next version.

Synfig<5544> [8:02:50] error: Advanced Outline:: sync<>: Exception thrown

The sync() procedure is under a try…catch handler so this is why the exception is thrown.

Glibmm-ERROR** Unhandled exception (type std:exception) in signal handler: What St9bad_alloc
Obviously I need to catch the std exception and handle it properly.

bad_alloc means that it has tried to setup a portion of memory and it couldn’t do it. It has to be related with the standard libraries. I have to work with the code to

  1. First, produce the same exception in one similar machine
  2. Try to handle it with a debugger to know who is causing the bad alloc.

I’m sorry for the inconveniences that this is producing.
-G

Try this one:
RixeyWriteOn-2.sifz (5.28 KB)
I’ve deleted the image layer and re done the animations. I did it using the 0.63.00 windows binaries on this Windows Vista machine. Now it plays fine here.
-G

Thank you for looking into my crashing problem. Sorry for my late reply. I have been traveling to the beach with my family. All I will have access to here for the next week is a Windows 7 laptop. The “RixeyWriteOn-2.sifz” that you created works fine (on this Windows 7 laptop). To answer your earlier question – yes, the file I created crashed on the Ubuntu computer (as well as two other Windows XP computers). For all the windows computers, I have used the 0.63.00 download.

Did you do anything special to recreate the file? If not, then maybe it is something I am inadvertently doing when I create the file (or, perhaps, something about the configuration of my computers).

If there is something I can do to help you reproduce the error please let me know.

Thanks,

StanH

It is definetively a bug in the code.
In your advanced outlines there are two widthpoints: one at start (stationery) and one that travels from the start to the end of the bline.
While you animated the second widthpoint position looks like you added some extra waypoints at the previous keyframes where the interpolation is being done.
In particular there are 4 keyframes in your file:

Start
com Outline
comp inner legs
comp collar

So, for example, inner legs layer widhtpoint position, starts to move form ‘com Outline’ to ‘comp inner legs’ but there is a extra waypoint at ‘com Outline’ where the widthpoint’s position is zero too.

Due to the nature of the TCB interpolation, the interpolation for a 0 -> 0 -> 1 values produce negative values between the travel from 0 to 0 (yes I know it is not what user expects see: viewtopic.php?f=14&t=1603)
Looks like those negtive values are not properly handled by the render routine and hangs Synfig Studio.

In your case, to avoid that bug just use Linear interpolation (ToolBox->Default Interpolation widget->Linear) by default and those negative values won’t appear.

When I re-did the animation I just used the lock keyframe past only and I were careful to not produce any unneeded waypoint.

I’ll try to fix that bug in the upcoming release (october probably).
-G

Your analysis is starting to ring some bells. Let us say that I had drawn 2 or so Blines and I was on the 3rd keyframe. I would draw my next Bline, set the width points to the Bline extremities, go into animation mode, move the time position several frames ahead, add a new keyframe, set the width point end points to “flat stop”, go back to the previous keyframe and position the ending “width point” position to zero.

Then, as I would review the animation or click on the various keyframes, I was amazed to see that this 3rd Bline was visible on keyframes 1 and 2. So the only option I thought I had (to make this Bline disappear) was to go back and reposition the ending widthpoint to position zero. (I didn’t expect to see that layer at all on the previous keyframes.) So, can you tell what I am doing wrong to have the subsequent Blines showing up in earlier keyframe? Of course, this not only causes a lot of extra work, it evidently causes the exception to be thrown and the program to crash.

How should the lock keyframes be set? On this windows 7 laptop, the “lock keyframes” icon is in the default “lock ally keyframes position”. Not really understanding what this does, I have not changed the default setting in the past.

Of course, I will follow your advice to use linear interpolation.

Thanks,
StanH

Maybe you should take a look to this:
wiki.synfig.org/wiki/Lock_Keyframes
wiki.synfig.org/wiki/Keyframe
wiki.synfig.org/wiki/Waypoints

-G