REALLY slow performance?

Hi all,

Synfig’s general performance is REALLY slow for me. So slow that I can see it filling a single rectangle. Here are my machine specs:

OS: Windows 7 Pro 64 bit
Processor: Intel Xenon E5 2GHz 2Ghz
Memory: 16GB
Video Card:NVIDIA GeForce GTX 480 (1.5GB @ 1848MHz)

I don’t see any way that it would be possible to animate with performance this slow. Am I missing something? Is there a setting I can change somewhere to speed this up?

W have not fixed the bugs in windows with multithreading so it has to run in single thread. It means that you have to render the scene in a single thread. Depending on the size of the image it can take its visible time in a single thread.
It is weird that you mention that a single rectangle renders so slow. Can you share the example file? Have you tried to run it in a 32 bits machine? May e there is something o the code that makes it worse for 64 bits machines (since the binaries are built for 32 bits)

I have not had a chance to try it on a 32 bit machine. All my machines are 64 bit.

As for the test scene, I am starting with the default scene, adding one rectangle with the default colors (b&w), and keying the translation from left to right (2 keys is all). Even when drawing the rectangle (without animation) the fill is visibly slow.

I need to access to a Windows 7 64 bits machine to confirm it. I don’t have anyone at hand by now.

No problem. This looks like a great program. I’d love to try it out. I’ve been doing limited animation professionally for many years (Disney, Cartoon Network) and I like what you guys are going for here. Lemme know if any solutions pop up.

What a tremendous computer you have… and can’t render a single square ??? are you a secret agent from adobe/flash trying to make some disorder in synfig room ?
Personally, i often use a not recent laptop [ cpu 0.8 to 1.6GHz , 1.2 Go ram , Ubuntu10.4.4 ] and i can render more than a square…

maybe installing gnu/linux ? (like others did in Hollywood…)

Héhé, i have one near me, and have already invited you there … it’s only one little sea to cross…


That sounds like something weird is going on. My PC is older than that, and the performance is way better than you describe. Core i7, 6GB RAM, 64bit Windows 7 Professional. Something’s going on with that machine.

Tried Synfig on one of my home PCs, same result. Here are the specs for my home machine:

Windows 7 Home Premium 64 bit
AMD Phenom II x4 Processor, 3.4 GHz
8GB Ram
AMD Radeon HD 6800

Are you using other gtk applications? Are they 32 or 64 bit binaries? Maybe there are interferences with the installed dlls.

GIMP 2.8.2. (64 bit) and Inkscape 0.46 (32 bit).

I have the exact same problem. Win 7, 64 bit. Synfig version is 0.63.05. Task viewer tells me that synfig does indeed spend most of my cpu cycles for a couple of seconds when updating the default view (like clicking the zoom-in button on an empty view).

hi… first off thanks for developing this great software!

i am having similar problems as described above here on Win7, Ubuntu12.10 and Debian7

i have created a fairly easy animation of nine consecutively animated PNG images all with dropshadow and motion blur and i am looking at render times of about 8h! when i turn off the effects (motion blur and dropshadow) it will render in 20min…

while trying to render from the commandline under linux i had no luck in getting that multithreading to work! i seem to be stuck on one core no matter what i pass it…

synfig -T 12 -a 2 -t png animation.sifz -o tmp/all.png

total time of the scene is about 45 seconds… the machine i am using is a monster xeon 24 core, plenty of RAM and several GFX cards but no avail… :confused:

oh and on my core2duo laptop the rendertime is about the same… :frowning:

is multithreading confirmed to be working on any system right now?

i will try to upload a stripped example of what i am doing…

Yup! Multithreading on Synfig works excellently on Linux (heck, nearly everything works excellently on it, even Blender!)

I use Ubuntu for most of my production, and have it dual-boot with Windows on the same PC.

ok… thanks to Genete i was able to cut render time into half just by encapsulating all my moving items into one group and applying the motion-blur only once to the whole group as opposed to having a motion-blur on top of every single item! it wasn’t that appearent to me that this would make such a difference!

@tushantin could you share your wisdom and at least provide a command line you successfully used to get multithreaded rendering accomplished with ‘synfig’ under whatever linux?

You did that and it didn’t explode??? :open_mouth: :open_mouth: