Problem with rendering MPG


just did my first simple animation (based upon the knight rider tutorial).
I rendered it as png sequence, which worked fine.

then I tried to render an MPG, but that failed.
In the Render dialog, I choosed the filename “out.mpg”. The target was set to auto. No errors occured.
the was an out.mpg generated, but when I want to do playback with VLC it play it, but doesn’t show any video picture.
What did I do wrong?

There were but probably silently in the console window.
Try to use ffmpeg instead of auto. IIRC, the codec mpg is associated to libavcoced which is giving us troubles to make work or compile properly.
Also please try to use Synfig 0.62.01 and experience the best results sending the video codec and bitrate to the ffmpeg renderer. I will do a nice work.

If this is where your media player opens the file without reporting an error but only shows a black screen or something similar, then I’ve had similar issues.

In my case, the video was exported with a resolution and frame rate that my video player and codec didn’t like - so it wouldn’t play back properly.

I’ve not managed to find the right settings in Synfig yet so I used a video converter to convert the rendered MPG or AVI file to something that my media player could cope with.

If you post the out.mpg, I’ll have a look at the details for you.


Have you tried ffmpeg target? Please select it in the target, write .avi in the file extension and in the just enabled button on the right of the ffmpeg target called “Parameters…” click on it and choose divx as codec and 600 or similar as bitrate. It must work fine.

OK, I got it.

Using the file extension .avi did it. In my tries I used .mpg as file extension and ffmpeg as target. That didn’t work.

Thanx for your help. Now I can continue learning synfig. :smiley: