Problem with layer order and skeleton deformation

Hello everyone,

I’m not sure if I have posted this message twice, but I don’t find the other, I’m sorry if the post is duplicate.

I just started tinkering with Synfig, just took a few days and now I’m trying to animate a character. The character is an exploded bitmap, which I imported into layers, each piece in a layer, I added a layer with a Skeleton deformation and have set up all bones.

Apparently everything works well with regard to the areas of influence of the bones, but when I start to put the pieces in the correct place, do not appear in the order they should, this should be from the bottom up: left arm, left leg, trunk, right leg, right arm and head and in the layers panel, appears keeping the left arm ZOrder value 6 and the head ZOrder with value 1.

But when I place the pieces to animate them, the trunk appears in first plane, I guess that this has to do with the skeleton and the “root bone” is this element that controls the trunk, but this is a guess on my part because I do not have read or seen anything about this.

Anyway, I can not get an arm and a leg on each side. Does anyone know about this please?

Thank you very much to all and best regards,


Can’t you just raise the layer of the right arm above the trunck and the head layer? I mean with the lower and raise layer arrows in the layers panel, not by fiddling with the z-depth. And if you can attach a sif file to the post. I find it easier to solve problems if when I load up the file myself.

Yes, I have tried to change the layer order, but has no results. The correct order is the order that is current in list.

I attach the sifz file.

Thank you very much

I can confirm that this is no bug. The deformation layer does not take its layer ordering from the layers panel but you have to set the z-order for each bone separately in the parameters panel of the deformation layer under the bones list. I fixed your file using this method.

todo: replace the over complicated cut-out tutorial using the Group Transformation Widget with a new simple cut-out using Deformation Layer.
simon_fixed.rar (1.59 MB)

Thank you darkspace65,

Indeed, it is not a bug. Konstantin Dimitrov replied the bug report and says: Skeleton Deformation layer doesn’t deal with layer order at all (because it works with “merged context”). You have to tweak “Z-Depth” parameter of each bone to define the order of parts.

But I continue with the problem. Your fixed file works fine (thanks), then, what happen? I’ve seen the bones and I see that when I select one, the bone is highligthed, the problem is that in your example, all the values of the Z-Depth is 0. I don’t understand. How can I set the depth if the value is the same?

When you make a new bone its z-depth will always be zero. Suppose you import a body and an arm. In The layers Panel the arm will have a z-depth of 1 and the body will have a z-depth of 2. The skeleton Deformation Layer will have a z-depth of 0. If you attach two bones to the arm then both bones will have a z-depth of 0 by default. You have to correct the z-depth of the Layers Panel by changing the number of the z-depth in the parameters Panel of the bone. So you will have to change the z-depth of the two arm bones to -1. As a result the 1 in the z-depth of the layers panel of the arm -1 of the z-depth of the bone will give the arm a real z-depth of 0 in the Layers Panel (although you won’t actually see that number appearing in the Layers Panel) and as such the arm will be placed correctly in front of the body. You will have to correct the z-depth of the bones of all bodyparts that seem to be in the wrong order. Also mind you, that when you, at some point, do reset pose again, all z-depth values of the bones go back to zero… :frowning:
Sorry if this sounds complicated but my native language is not English.

:open_mouth: :open_mouth: :open_mouth:

I’m afraid that I need to read this a couple of times again :mrgreen: :mrgreen: :mrgreen:

Thank you for your explanation. I think that I will try understand this tomorrow in the morning, now it’s time to sleep in Spain :wink:

If you are still struggling with it tomorrow then I will make a step by step tutorial in a small video using the torso and the arm of your simon character as an example. :slight_smile:
Greetz! (and goodnight!)