Non predictable crashes when moving through timeline

Okay, so, it goes like this: sometimes when i open a project (i mean a specific project as it doesn’t happen with all of them) and try moving the cursor on the timeline Synfig will crash for no aparent reason. I’m using windows 8.1 with a dual-core multi threaded core i3 cpu and no dedicated graphics, currently using version 1.2 but i’ve had the same problen on 1.3.3. Could it be that my machine is not capable enough? I’m not all that sure since it has not happened with other projects.

Here’s the project i’m talking about:
HexagonSlice.sifz (8.56 KB)

There is something wrong with your file.
When I open it it crashes too.
Rename it as zip and extrat the inner file.
There are duplicate GUIDs, juste find them and change one of each pair, then repack the file.
It should work.

i’m a bit confused, i changed the .sifz’s extension to .zip and extracted a file that i couldn’t open so i changed it’s extension to .txt and opened with notepad++. Now the thing is, what exactly am i looking for?

Sorry for beeing such a noob, i still have a lot to learn.

Don’t worry, only the ones who don’t learn new things are not noobs anymore :slight_smile:

First, you should name the extracted file as .xml instead of .txt.
It will help for code folding, syntax color, validation…

After this, you can search for guid= pattern.
It is a unique identifier for some elements (like bline in your case).
The problem is that these “unique” identifiers can sometimes be duplicated :cry: (yes, it should not)
Just replace the last hex digit(0-9, A-F) to make it unique again

For example let the first one as

but change the second one

Repack and you can open it :slight_smile:

Beware, your file can be corrupted, some elements missing.
Like always, do often backup copies of your work, just in case a file would get corrupted.
You will then be able to restore one step before :slight_smile:

Good luck

Thanks! i just did what you sugested and, indeed, it doesn’t crash anymore! but that’s because it doesn’t even open now. It shows an error when i try to open that says:

                    "Unable to load: Document not well formated. Line 1 Column 1 (fatal): Extra content at 
                     the end of the document". 

To be honest it doesn’t make much sense to me since (as far as i know) i didn’t change anything on line 1. I’ve also discovered that just extracting and repacking the original file causes the same error, so, am i repacking it the wrong way?

As a side note i would like to report that the original document doesn’t crash consistently on version 1.3.3, sometimes it does, sometimes it doesn’t. I’m sorry if i’m wasting your time. Regardless i will be posting both the original and the modified .xml files in case i did something wrong. I do want to apologize once again in case i’m being to big of a bother, i’m sure mine is not that big of a problem. :confused:
HexagonSlice(original).xml (272 KB)
HexagonSlice(modified).xml (272 KB)

Sorry, I didn’t mention the fact .sifz is gzipped (not just zipped)
What you need to do is rename your modified file with .sif (uncompressed) and open it in Synfig :slight_smile:
Then you will be able to save it later as .sifz :wink:

Thanks a lot! It worked! Now it doesn’t crash anymore (as far as i’ve tested). I’ll leave the fixed file in case you (or anyone else) want to use it or modify it. And finally, i would like to ask what do you think about it? is there something i’m doing the wrong way? Am i taking “the long path” on something that is actually simple? Thanks for your time and for helping me solve my problem. :smiley:
HexagonSlice.sifz (8.36 KB)