NEWBIE How to get an imported image to display on the canvas

Now that I figured out how to import an image- I can’t get it to display on the screen. I see a layer with a folder with the files name but I can’t open it.

The layers box shows z depth, which I don’t understand yet. The png image has 0 zdepth and the jpg image has a zdepth of 1.

The DOS screen says this:

synfigstudio.exe:3640:Gtk-CRITICAL88: gtk_tree_mode1_get_iter: assertion ‘path->depth > 0’ failed

and then says I supposedly moved zero layers and that the rename failed.

JPEG can’t be displayed using Cairo render. Check that you have it disabled in Preferences and so it uses the default internal renderer.

I forget where to find that setting but the dos screen reports an error after afresh install even before I try to import an image and suggest that I needto install hicolor-icon-theme. I downloaded the one with the latest date but the install instructions say "To install this package in /usr just run:
make PREFIX=/usr

Windows didn’t accept “make”

The Dos screen also say s it could not find the icon ‘gtk-execute’ but I think it is saying the solution is to install hicolor-icon-theme

i amusing the 64 bit version of Synfig but also tried the 32 bit version, which didn’t work

Those are Linux instructions, that’s why they don’t work on Windows. :wink: You don’t need this “hicolor-icon-theme”.

Also, you don’t necessarily need to worry about every warning that shows the DOS screen when you run Synfigstudio. Only when something doesn’t work should you try fixing it. Most of the warnings can simply be ignored.

What you should do is disable Cairo render in File > Setup > Render window. That should allow imported JPG files to show. That’s assuming PNG files already show properly.

If that doesn’t work then there might be something wrong with Synfigstudio itself on Windows, which would need to be fixed by a coder.

Thanks for the info but neither of the Cairo reader boxes are checked and so it does not appear to be enabled and I do have the same issue with png files.

I have been thinking about backing up my hard drive and doing a restore to the factory default on my PC- if so, I will try installing SynFig studio after that.

Then you have a different problem.

Which version are you using? Latest stable version is 0.64.1:

O am using th elatest version for 64 bit. I also tried the 32 bit.

Solved by installing my system back to the factory default. First program I installed after security is Synfig. Now I can import an image and it displays instantly.

Probably there was some permission issues that did not allow Synfig to load the image file. Happens on Windows 7 occasionally.

I worked through a lot of tutorials lateley but couldn’t find anything like this. The reason might be that this is really hard even theoretically…