Needing help with import/animate in Synfig.

Hello, a new Synfig user here.

I’ve been trying to import some text-like .svg from InkScape to Synfig, only now it won’t show up. Is this something that’s being worked on?

I have imported some text on a few tests and it has worked, trying to do the animation part is something I need to work on. Wish there was a way to get some of the letters (for instance an O) to be cut out and not fill it.

Everything works (making shapes and text [which seems limited to just Sans Serif]), but I can’t seem to get my vectors into the program.

I’m using Synfig .63.5



Here’s one attached file I did, by applying .svg from InkScape to Synfig. Rendered instead with .mp4/ffmpeg extension.

Everything worked fine - to a point (can’t seem to get the outside of both the R or O to come out right, must be an object connection problem).

But now, I can’t import any .svg vector in Synfig, and when imported, it nothing comes up. (133 KB)

The preferted way to use svg file is use sif exporter in Inkscape SIF output extension to ship in Inkscape 0.49, needs testing

I tried the sif2svg export for InkScape and send to Synfig. No such luck. I open Synfig, right click on File/Import, select my file.sif and then… nothing. No image, nothing. Tried to open the file in a new one the same thing. Checked the command prompt (synfig<9332> [11:10:18 PM] info: Attempting to import C:\Users\XX\Desktom\MyAniTest\XX.sif

I have no idea of what’s going on. When I close the program, I get a program stopped working error. Maybe I need to reboot.

could you attach your sif exported from Inkscape, so that I can have a test on my machine.

Most certainly.

I will Attach 3 files. The .sif file of ElDiablo (the test) in Inkscape, and 2nd. test to import the .sif file.

Thridly, here’s the Metro test file when I imported my .svg file to Synfig.

Hope this helps.

Synfig Animation 0a.sifz (4.84 KB)
ElDiabloTest2.sifz (437 Bytes)
eldiablo.sif (191 Bytes)

The eldiablo.sif is a canvas without any layers inside. Did you use sif exporterwe mentioned to convert your svg file to sif ? If not, pls try that one, if yes, pls attache the svg file here for test.

I did the sif converter as we said. Exported to .sif and went to Synfig, and no layers. Here’s the El Diablo .svg file. It’s a text.

One thing I notice when using the exporter, I go to Extensions and select Synfig Exporter, then a popup appears - Preparing to to export, please wait, something happens and that’s it.

I don’t know what’s going on. Last time I imported most of my text vectors into Synfig with no problems, now I can’t seem to get both .svg or .sif (the exporter).

Thanks for all your help; I appreciate a response.

Are you using the ‘Save As’ command to save as a Synfig animation? The ‘Prepare for export’ option in the extensions menu is just that: it prepares to export the file, but doesn’t actually export it. I should remove it to avoid confusion.

I’ve attached the sif file I get on my computer. I went to “File > Save as” and selected “Synfig Animation (*.sif)” it the filetype dropdown menu before saving.
elDiabloTxtDraw.sif (85.3 KB)

I tried your attached and it worked.

I tried to test again in InkScape and followed your instructions. I used “Save As” under File menu and applied .sif under my file name and it was saved. But, upon selecting the .sif file, I get a blank canvas. My second testing of the .sif file under Inkscape is only 1 kilobyte. I don’t know what’s going on. Maybe I’m using an all too sophisticated font, or maybe I’m using an old version of InkScape (verson 4.8).

I also have another Vector Graphics program - CorelDraw X4; maybe it’s colliding with what I’m working on.

I wish I can figure this one out.


I manage to see what’s going on… I think.

I rebooted my system.

What I wanted to do was create animations in Text. What I did was go to Inkscape, make the elDiablo text, and I had to “Convert object (text) into a path (Ctrl+Shift+C)”, save my file in .sif format, save it again in InkScape .svg and I manage to get the text into Synfig with no problems.

However, upon loading it, my “e” part is wrong. I don’t want to use the ‘duck’ parts to correct it, so…

See attached.

I think I’m getting the hang of it.

On Windows Vista – I selected InkScape .svg for any future vector graphics I do and not let it collide with CorelDraw.

Any tips would be appreciated.

Whenever you convert text to outlines in Inkscape double nodes are produced - two nodes stacked on top of each other in the same place. In fact, in each bit of outline there is one double node, so in an “e” there would be two double nodes - one in the middle of the e and one on the outside.

First of all, so see where the double nodes are use the nodes tool and select the outline. The double (or sometimes triple) nodes look different to the others.

You then need to join the nodes together by selecting them and using the “join selected nodes” button on the toolbar. After you have done this the text will export from Inkscape as a .sif properly.

Thanks DaveJ and all for all your help.

I tried it, no such luck. When I join nodes together, saved under .sif, and still get object/nodes all over the place. Granted I’m quite a newbie at this.

I appreciate all the help.

Hmmm… this could be a problem with the font you’re using, but difficult to know for sure as I don’t have a copy of it.

I tried converting your svg file to .sif using the method I posted above and I didn’t have any problems.
elDiabloTxtDraw.sif (83.4 KB)

I see. I tried the attached that was from nikitakit’s part, it worked.

You maybe right that it could be a ‘font’ issue on my side.

Attached is the Veranda (Windows Vista, Windows XP) font I used. I don’t know what the situation is, maybe someone can figure this out.

Thank you.
edFontTestVeranda.sif (90.7 KB)


I think I got it… as I say, I think.

The other method of getting said text of different font, while joining nodes didn’t work for me at all. It only send the outer part of my text in so many different positions.

In order for me to get correct text in Inkscape into Synfig, I…

1). Make the text

2). Chose object to path, and select the object paths.

3). I select “Break Apart”

4). In order to close the holes of text (a, e, i, o, u, etc.), I selected either “Difference”, or “Exclusion”, except for the i, where I had to break that apart.

5). I check to make sure that I did all text object (selecting “Difference” e.g.) one by one.

6). Then I “Save to Copy” my file under the .sif extension.

Then, I double-click on my saved .sif file, and it gives me the correct text creation that I did.

It’s a very complicated process to do (now, I cannot say that I found a solution), but I managed to work up something.

With that, I attached a file

What I want to acomplish in doing is to make a Title/Credit Sequence in Synfig similar to that of Adobe After Effects.

I thank you very much for all the assistance provided.

If there are any suggestions/workarounds, I appreciate them.

Ah, I think I know what the problem was now - it’s the winding order.

For a vector program to work out where holes are it looks at the direction that order nodes appear in the outer outline (clockwise or anti-clockwise). Then it looks at node order in the inner outline (clockwise or anti-clockwise). When the two orders are wrong it causes the problems you saw.

What you’re doing by breaking apart the letters and then subtracting the hole outline from the letter outline is ensuring that the path node direction of the inner path is correct for the outer path.

The only reliable way to fix this is the way you describe. There is Path -> Reverse in the Inkscape Path menu but as Inkscape doesn’t show you the direction of the nodes so you might be introducing a problem that isn’t there by using that.

Anyway, I’m delighted you solved the problem! 8)