Modify "Frames per second" while leaving the animation untouched otherwise

I already have some animation. I’m noticing in retrospect that the value in Canvas/Properties, tab “Time”, Time settings, Frames per second, is wrong: it is 24.0000 and the animation has been constructed on the assumption that it is 12.00000.

So I’d like to modify this value from 24.00000 to 12.00000, in a way that leaves the animation completely unchanged otherwise. Each frame should stay exactly as it was. No recalculating keyframes, no nothing. Each keyframe should have exactly the same frame number as before. Just the value “24.00000” where the value “12.00000” used to be.

Is there an easy way to do it?

I’ve noticed that the tab “Locks and links” gives many options to keep aspects of the animation unchanged. But none of them seem to be time related.


It shouldn’t recalculate anything. You change frame per second not time boundaries. Did you actually try that? It should work as expected.

Alternatively, you can leave global fps as 24. On top of your animation you want to have 12 fps put ‘Time->Stroboscope’ layer and set its ‘Frequency’ parameter to 12.

Did you actually try that? It should work as expected.

I did try that (i.e., changing the value for frames per second, but seeing to it that start time, end time and duration remained the same).

When I “applied” the change, all the keyframes ended up at half their original frame numbers. Synfig does seem to recalculate frames when the frames per seconds are modified.

Oh, well, and it is indeed correct :slight_smile:
Stuff done at 48f (=2s with first setup 24fs) now is done at 24f (=2s @12fs) as you wished.

Oh, of course, I had my keyframes set on whole second boundaries so I didn’t notice when I was testing. Silly me.

Hmm, I don’t think there is a way to recalculate it automaticallyy, but as a workaround, try setting ‘Speed’ parameter of group layer your animation in to ‘2’. This should compensate for the frame drop if I understand this correctly.

Save your animation as .sif file. Open it with any text editor and change fps="24.000" to fps="12.000".

I think that won’t fix: the keyframes and waypoints are stored as time points, not frame numbers.

This is bug in the Synfig. It shows FPS not for document, but preferred FPS.

Yes. So we just reduce frame rate for animation. Or I miss something?

Well, I dunno lol :slight_smile: