Menus showing up on second screen

Hi there :slight_smile: I just started using Synfig (version 1.4.4) with a 2-screen setup. When I open the program, for some reason it always opens on my second monitor. This wouldn’t matter, except if I move the window to the first monitor, whenever I click on a menu at the top (file, edit, view, etc.) or right click to pop up the menu, the menu shows up on the second screen instead of the first (where the program actually is located). Everything works fine if I move the window back to the second screen. It’s not a huge problem, but I wonder if somebody knows how to fix it, as I like using the app on my main monitor. Things I’ve tried:

  1. I tried switching to single monitor mode, and everything works ok. I also tried opening Synfig in single monitor mode and then switching to dual mode, and the issue is still there.

  2. I tried installing version 1.5.1, as suggested in this post:
    When right clicking, menu appears on second screen - #2 by rodolforg
    but when every time I tried to open it, the initial loading of the program stalled at “checking auto-recover” (or something very similar to that), and froze. I’m using windows 7 64 bit with service pack 1.

If anybody knows of a way to make the issue stop in version 1.4.4, or how to get version 1.5.1 working, I’d appreciate suggestions.

Thanks for any time and help!

Could you please attach a screenshot to illustrate better

It seems to be a well known issue about GTK, when the 2 screen are aligned on the same line.
In some case, it is said that the menu is opening on the screen which has the HDMI connector (try to select it as primary).
In some other cases, you can “fix” it by moving one screen slightly up in the display configuration.

Thanks so much for the info! I hate to say I kinda wasted your time though. I forgot the number one solution for all computer problems: restart the computer. I turned mine off because of a thunderstorm the other night, and after turning it back on, the issue is no longer there! So, for future reference, if anybody has this problem, just restart your system and see if that works.

From the show “I.T. Crowd”: “Have you tried turning it off and back on again? Are you sure it’s plugged in?”

It may also because the computer started with the configuration already activated.
Sometimes the drivers don’t take into account properly new elements like when you added the secondary screen or defined which one is the main screen.
Starting from scratch is often better (like a Raspberry Pi that doesn’t recognize a screen that was not plugged at boot, you have to reboot to make it work)