MacOS X dmg/app package - please test


#29

giantspacebug:
Also, please verify md5sum for downloaded .dmg package:

$ md5sum synfigstudio_0.63.04_1_i386.dmg 8413663ff531a821793ce51860d106a6 synfigstudio_0.63.04_1_i386.dmg


#30

That would be great Zelgadis. As I wrote, only the last step, the “synfig” dependency compile, doesn’t work. So if there’s a way to fix that, I would be glad for assistance. My unix knowledge is too poor to figure it out myself.

No rush. Thanks!


#31

goestas:
Please run macports compilation and post the error message you have.


#32

I did a manual sync & update outdated before trying again. Message is the same as before:

localhost:local goesta$ sudo port install synfigstudio
—> Computing dependencies for synfigstudio
—> Dependencies to be installed: synfig
—> Building synfig
Error: Target org.macports.build returned: shell command failed (see log for details)
Error: Failed to install synfig
Log for synfig is at: /opt/local/var/macports/logs/_opt_local_var_macports_sources_www.macports.org_files_ports_graphics_synfig/synfig/main.log
Error: The following dependencies were not installed: synfig
Error: Status 1 encountered during processing.

thanks!


#33

The md5sum is correct.


#34

And lastly trying opening with sw renamed, looks like the same result as before.

[code]arkon:~ keith$ /tmp/skl/SynfigStudio.app/Contents/Resources/bin/synfigstudio

synfig studio – starting up application…

Xlib: extension “RANDR” missing on display “/tmp/launch-iLBgVG/org.x:0”.
synfig(37884) [23:17:03] info: Loading modules from /tmp/skl/SynfigStudio.app/Contents/Resources/etc/synfig_modules.cfg

(synfigstudio:37884): GLib-GObject-CRITICAL **: Object class gtkmm__CustomObject_N6studio15ValueBase_EntryE doesn’t implement property ‘editing-canceled’ from interface ‘GtkCellEditable’

glibmm-ERROR **:
unhandled exception (type std::exception) in signal handler:
what: error while reading from input stream

Trace/BPT trap
Zarkon:~ keith$ [/code]


#35

OK, that’s good. Looks like I know the solution.
Please execute following command and post output here:

cat /opt/local/var/macports/logs/_opt_local_var_macports_sources_www.macports.org_files_ports_graphics_synfig/synfig/main.log | tail -n 30

giantspacebug:
Thank you for testing. Looks like it’s not related to the Fink installation and the dmg file is correct. Sorry, I’m out of ideas what could be wrong in this case. :frowning:


#36

giantspacebug:
OK, looking here - synfig.org/forums/viewtopic.php?f=12&t=3211 - I’m starting to think that the problem may be related with your version of X11. But i haven’t much knowledge about X11 on mac, and doesn’t even know how to figure out which version of X11 installed…


#37

The x11 version I have is called XQuartz 2.3.6. (xorg-server 1.4.2 apple56) There is a later version 2.7 what version of x11 is synfig supposed to use? Maybe I can figure out whether I need to upgrade Xquartz.
Also I am remembering an earlier issue with libmm and glibmm on OS x, as in OS X uses glibmm(?) instead of libmm, libmm popped up in the error messages I believe, does anyone think it could be related to that?


#38

Hwere you installed your version of X11 from? I guess you need the one from the OS X install disk. It is included on the “Optional Installs” package on the disk…


#39

This 10.6+ only?
Too bad, there are still people using 10.5.8 you know…


#40

Yes that is what I have.


#41

We don’t have a package maintainer with OSX 10.5.x.


#42

Package works: yes so far so good
Your OSX version: 10.6.8
Your OSX arch: macbook pro 2.26 core 2
X11 installed: yes
Report if additional build tools installed: MacPort / homebrew / fink

After computer asleep had to force quit before shut down since it said it was still running program was not visible except in force quit window

Any downloads for my old brain? ha ha


#43

Hi!

I recently (actually today) downloaded the Mac test .DMG of Synfig Studio. Here is my problem. I cannot open it. The X11 Terminal window does not open up either. I also have Synfig installed through Fink. Could this be a conflict clash between the two packages? I was thinking of uninstalling the Fink package of Synfig if this worked anyway. Also, do I need to do anything else to make this work? I am using an iMac 27-inch (late 2009) with a 2.8 GHz Core i7 processor, 4 GB of RAM and Mac OS X 10.7.3 Lion. Any help is duly appreciated, as always. Thanks for the support. :smiley:


#44

Hi, onkilter180!
Please verify the md5sum for downloaded .dmg package first:

$ md5sum synfigstudio_0.63.04_1_i386.dmg 8413663ff531a821793ce51860d106a6 synfigstudio_0.63.04_1_i386.dmg

You can avoid uninstalling of Fink, just rename “/sw” directory to something like “/sw-bak”.

Next, open dmg and double-click the SynfigStudio .app file there.
If nothing happens then open terminal and enter following command:

/tmp/skl/SynfigStudio.app/Contents/Resources/bin/synfigstudio

Please post the messages you will have in the terminal. Thank you!


#45

Well, actually, what I meant by not being able to open it is I installed the application but cannot open the newly installed version of Synfig. However, I still will try your advice and do a checksum of the MD5 on the program. Thanks. :slight_smile:

P.S. That’s right. It was not an installer package but a program to be immediately dragged and dropped into the Applications folder. Sorry. I forgot about that. Thanks again.


#46

One more thing, I forgot how to do a checksum of the application on the Terminal shell. Could you tell me the shell command to go through with that procedure? Sorry about the delay in asking. I am a busy man. Thanks! :smiley:


#47

Hi, onkilter180!
Please use this command to verify checksum:

md5sum /path/to/synfigstudio_0.63.04_1_i386.dmg

the correct checksum is:

8413663ff531a821793ce51860d106a6

#48

Well, I tried the md5sum command on the Terminal. The command was not recognized on the bash window. So, I am stuck again. I typed “cd desktop”, for that was where the .DMG file was at. It did not work. Bummer. Any more hints? Thanks. :slight_smile: