MacOS X dmg/app package - please test


#1

Hi!
OK, it’s time to announce that I have managed to pack synfig studio into dmg/app.
I have used the same approach as Gimp for OSX build, described in this manual.
After spending 3 nights on build process here’s the very first package I did and it needs testing.

Download: sourceforge.net/projects/synfig/ … g/download
md5sum: 009df37b0435fdc8cc9b7100dfb39433

Sorry for the big size of the package - it is have a lot of stuff to clean inside. I don’t want to do cleanup until it will be confirmed that approach is working.

Please test and feedback in following form:

Package works: yes/no Your OSX version Your OSX arch X11 installed: yes/no Report if additional build tools installed: MacPort / homebrew / fink

Thank you!


#2

Zelgadis, Thanks for your job.

I downloaded and tested with some simple sifz files.

Package works: yes
OSX version 10.7.2
OSX arch 64bit
X11 installed: no
Report if additional build tools installed: none

Except lacking of Synfig Logo for the synfigstudio.app,
Everything works just fine!


#3

Re-hurray!! \o/ :open_mouth: :open_mouth:
-G


#4

Here’s results of my tests:

Package works: yes OSX version 10.6.2 OSX arch 32bit X11 installed: yes Report if additional build tools installed: none

Package works: yes OSX version 10.6.8 OSX arch 32bit X11 installed: yes Report if additional build tools installed: none

EDIT: On both tests synfig was able to run and do some things, but its crashy as hell. Does it result of my packaging or is that characteristic behavior for all MacPorts builds? I don’t know…

I also wrote an automatic scripts so anyone can build such package on his own mac. Will publish soon together with guidelines on the wiki.

About synfig logo - yeah, I guess that could be easily fixed. :slight_smile:


#5

Great work Zelgadis
I have tried myself to build synfig with Homebrew and Macports but failed to get it to work. This is the first time I have been able to test synfig out. Synfig starts OK but chrashes when I change tool from rectangletool to circletool or the paint bucket.

my specs:
MacBookPro5,2
Intel Core 2 Duo, 3.06 GHz,
Ram 4 GB DDR3, 1067 MHz
Graphics: NVIDIA GeForce 9600M GT, NVIDIA GeForce 9600M GT, PCIe, 512 MB
Graphics: NVIDIA GeForce 9400M, NVIDIA GeForce 9400M, PCI, 256 MBMac
OS X Lion 10.7.2

There is a chrashreport at
pasteall.org/29149

I hope it is helpful


#6

Package works: not really
Your OSX version 10.7.3
Your OSX arch 64bit (I think?)
X11 installed: yes
Report if additional build tools installed: MacPort / homebrew / fink (current homebrew installed, old fink/Macport installation bits may be lying around. On this machine I did not use Homebrew to install synfig. On my other machine I am trying to run a Homebrew-installed synfigstudio, which crashes on startup)

Try 1: App starts fine, I draw a circle, click on the selection (“arrow”) tool, click in the canvas, it crashes as follows:

Process: synfigstudio [658]
Path: /tmp/*/SynfigStudio.app/Contents/Resources/bin/synfigstudio
Identifier: synfigstudio
Version: ??? (???)
Code Type: X86-64 (Native)
Parent Process: SynfigStudio [656]
Date/Time: 2012-02-15 19:26:09.206 +0100
OS Version: Mac OS X 10.7.3 (11D50)
Report Version: 9

Interval Since Last Report: 1133007 sec
Crashes Since Last Report: 1
Per-App Crashes Since Last Report: 1
Anonymous UUID: 32FE5AD2-E721-4DE5-BC1A-2B7908059D8F

Crashed Thread: 0 Dispatch queue: com.apple.main-thread

Exception Type: EXC_BREAKPOINT (SIGTRAP)
Exception Codes: 0x0000000000000002, 0x0000000000000000

Application Specific Information:
objc[658]: garbage collection is OFF

Try 2: App starts, I create 2 circles, change to “Transform Tool”, app crashes immediately. Here more detail:

Process: synfigstudio [1013]
Path: /tmp/*/SynfigStudio.app/Contents/Resources/bin/synfigstudio
Identifier: synfigstudio
Version: ??? (???)
Code Type: X86-64 (Native)
Parent Process: SynfigStudio [1011]

Date/Time: 2012-02-15 19:31:58.285 +0100
OS Version: Mac OS X 10.7.3 (11D50)
Report Version: 9

Interval Since Last Report: 1133350 sec
Crashes Since Last Report: 2
Per-App Crashes Since Last Report: 2
Anonymous UUID: 32FE5AD2-E721-4DE5-BC1A-2B7908059D8F

Crashed Thread: 0 Dispatch queue: com.apple.main-thread

Exception Type: EXC_BREAKPOINT (SIGTRAP)
Exception Codes: 0x0000000000000002, 0x0000000000000000

Application Specific Information:
objc[1013]: garbage collection is OFF

Thread 0 Crashed:: Dispatch queue: com.apple.main-thread
0 libglib-2.0.0.dylib 0x0000000101e34f26 g_logv + 598
1 libglib-2.0.0.dylib 0x0000000101e35244 g_log + 148
2 libglibmm-2.4.1.dylib 0x0000000101768927 Glib::exception_handlers_invoke() + 311
3 libgtkmm-2.4.1.dylib 0x0000000100db67fd _ZN12_GLOBAL__N_1L35Widget_signal_expose_event_callbackEP10_GtkWidgetP15_GdkEventExposePv + 109
4 libgtk-quartz-2.0.0.dylib 0x000000010138c7ff _gtk_marshal_BOOLEAN__BOXED + 95
5 libgobject-2.0.0.dylib 0x0000000101d9b984 g_closure_invoke + 292
6 libgobject-2.0.0.dylib 0x0000000101db1c7e signal_emit_unlocked_R + 3150
7 libgobject-2.0.0.dylib 0x0000000101db341f g_signal_emit_valist + 1391
8 libgobject-2.0.0.dylib 0x0000000101db3b84 g_signal_emit + 148
9 libgtk-quartz-2.0.0.dylib 0x00000001014a279e gtk_widget_event_internal + 574
10 libgtk-quartz-2.0.0.dylib 0x0000000101386762 gtk_main_do_event + 1650
11 libgdk-quartz-2.0.0.dylib 0x000000010182fbfa _gdk_window_process_updates_recurse + 618
12 libgdk-quartz-2.0.0.dylib 0x000000010182fc3a _gdk_window_process_updates_recurse + 682
13 libgdk-quartz-2.0.0.dylib 0x0000000101835bc9 -[GdkQuartzView drawRect:] + 361
14 com.apple.AppKit 0x0000000102615bab -[NSView _drawRect:clip:] + 3995
15 com.apple.AppKit 0x000000010261385d -[NSView _recursiveDisplayRectIfNeededIgnoringOpacity:isVisibleRect:rectIsVisibleRectForView:topView:] + 3020
16 com.apple.AppKit 0x000000010260d9af -[NSView _displayRectIgnoringOpacity:isVisibleRect:rectIsVisibleRectForView:] + 4755
17 com.apple.AppKit 0x0000000102606395 -[NSView displayIfNeeded] + 1528
18 libgdk-quartz-2.0.0.dylib 0x0000000101846ca2 _gdk_windowing_after_process_all_updates + 98
19 libgdk-quartz-2.0.0.dylib 0x000000010182dd5e gdk_window_process_all_updates + 286
20 libgdk-quartz-2.0.0.dylib 0x000000010182ddd9 gdk_window_update_idle + 9
21 libgdk-quartz-2.0.0.dylib 0x0000000101809549 gdk_threads_dispatch + 89
22 libglib-2.0.0.dylib 0x0000000101e2b56d g_main_context_dispatch + 493
23 libglib-2.0.0.dylib 0x0000000101e2eff4 g_main_context_iterate + 916
24 libglib-2.0.0.dylib 0x0000000101e2f355 g_main_loop_run + 469
25 libgtk-quartz-2.0.0.dylib 0x0000000101386980 gtk_main + 176
26 synfigstudio 0x0000000100015ba2 main + 290
27 synfigstudio 0x0000000100015a78 start + 52

Hope this helps. Do you think I should uninstall fink/Macports/Homebrew?


#7

goestas:
I think the problem is not related to homebrew/Fink/Macports because I have exactly the same experience in my test. I.e. synfig crashes when clicking on created circles.

So I think we have 2 conclusions:

  1. The packaging approach generally works fine - reports here sar that people can start application on various versions of OSX (10.6.x and 10.7.x)
  2. The crashing behavior of synfig is related to general synfig unstability on mac OSX. And is not related to proposed packaging method.

Though, the last statement requires confirmation from users, who have synfig installed purely with fink/macports/homebrew. If they have different experience (synfig works more stable for them) then my second statement is untrue and we have to digg further with packaging approach.


#8

Hi Zelgadis!

This is just a quick response on this, I have not tried your dmg file, however I have the latest synfig build running, I installed it from the source files and compiled it with the terminal, ( in other words, I did not install Synfig using “sudo port install synfigstudio” command).
I say this is just a quick response because I have not used Synfig a lot for a long time, but I started it up and made a small animation on it and I have no crash at all, it seems to be running ok and I don’t have this “making a circle” crashes your talking about.

A quick question, did you make the dmg file using macport and the command:
sudo port mdmg synfigstudio?

That command is what I have tried a couple of times and I always end up with an installation file that behaves like you described it after installation on another machine.

Cheers / Ulrik


#9

Hi, ulrik!
Thank you for the feedback.
Please provide your version of Mac OSX. Also, what configuration you have in your etc/macposrts/variants.conf?
Your feedback is very important.
I haven’t used “port mdmg” command - everything is packed into app manually.

Can you find time and try dmg file from this thread on YOUR machine?
Thank you!

P.S. C’mon, mac os user! Do you want precompiled synfig binaries? We need more feedback!


#10

This is my variants.conf

To specify global variants to use for all port builds,

customize this file to list variant settings you want.

Any variants specified here that are not supported by

a port will just be ignored. Multiple variants can be

specified per line, or one per line is also allowed.

Example:

+ipv6 +no_x11

Nothing there, I checked the “variants.conf.default” as well and no variants there as well.

My osx is 10.7.3

I’ll try install from your dmg file later, I’ll keep in touch.

Ulrik


#11

OK, thank you!
I can see that my variants.conf is different. :slight_smile:


#12

Hallo Zelgadis

One idea to get more people to test the builds might be to put a build up on graphicall.org. Maybe you can get more feedback there.


#13

Is the process you used to compile it understandable to someone who can just about copy & paste commands into Terminal? If so, could you share it until a working installer (Macports/Homebrew/Disk Image, don’t really care … well, of course I would prefer a install package on .dmg!) comes around?

Cheers


#14

At the top of this side is the way I install it:
synfig.org/forums/viewtopic.php?f=13&t=2851


#15

Downlading and testing, will come back with the results…

I should note that a few months ago i got a working .pkg (installed and worked in my dev test machine) installation (for Snow Leopard) but mi disk crashed and didn’t tray again (i’m in Lion now, and in that previous attempt i spend like 2 or 3 days on it, i was stable and could make an animation but my main motivation was to use it with a wacom tablet and that configuration didn’t worked at all)…

UPDATE:

The same problem that others have reported, any interaction after using the drawing tools resulted in a crash. Computer ultra slow after the crash in some isolated cases.

Error that got my attention at start up:
2/16/12 11:37:31.618 PM [0x0-0x2b52b5].SynfigStudio: (synfigstudio:2186): GLib-GObject-CRITICAL **: Object class gtkmm__CustomObject_N6studio15ValueBase_EntryE doesn’t implement property ‘editing-canceled’ from interface ‘GtkCellEditable’

Don’t know how important but ejecting the dmg image resulted in the app not even running, just with the console message:
2/16/12 11:40:36.445 PM [0x0-0x2bc2bc].SynfigStudio: ln: /tmp/skl/SynfigStudio.app: File exists

This is caused by running the app directly from de dmg, and then trying to running it from a copy in your hard disk, could cause problems too if the app is moved after the first run.

Fix - delete the symbolic link via terminal command: rm SynfigStudio.app in the folder /tmp/skl/

Package works:no
Your OSX 10.7.2 (will try again with 10.7.3 but almost sure will not work)
Your OSX Intel
X11 installed: yes
Report if additional build tools installed: none


#16

Can you describe in few words your approach how did you get your dmg? Thank you.

Thank you for the idea. I think graphicall.org won’t help us at the moment, because right now we need a feedback from people running self-compiled stuff to compare.


#17

To be honest it was a mess, i was not particularly careful, just was really obstinate to get it working, so made multiple attempts randomly to see what worked following the forum tips, macports was just errors from the beginning, not working at all, then tried fink, got it to maybe 60% of the compilation and then was a dead end, finally with the homebrew process i got a running app (after solving a few dependency issues i think), stable as far i know (5-6 hrs of testing on normal animation use), although may note that both of my machines are developer intended so i have the developer tools and X11 installed by default.

Will be trying again to compile it, next week and post the results… sorry if the description wasn’t so short…


#18

Could you post how you fixed the Homebrew install in my thread:[url]Mac OSX Homebrew install aborts on running synfigstudio]

I would love to at least get one working install, while waiting for the .dmg issues to get sorted. Thank you!

Cheers, G.


#19

OK, we have following variables that may be affecting observed synfig instability:

  1. The version of synfig is 0.63.04 - others not reported which version of self-compiled synfig they were tested. That may be the case.
  2. Custom prefix. I have used custom prefix for macports to make it possible to pack into app. I wonder if that makes any influence.
  3. I have used custom variants.conf by adding this line: “+universal +no_x11 +quartz” - that may be affecting to.

I will publish my scripts an instructions as soon as I will have time.

edlnovo:
Thanks for reporting /tmp/skl error - that will be fixed.


#20

OK, I have removed all options from my variants.conf file and did a full rebuild. And… Wow, I can create circles now!
Here’s the new build, please test:
download.tuxfamily.org/synfig/pa … 1_i386.dmg