Mac OSX Homebrew install aborts on running synfigstudio

Finally managed (I thought) to install using Homebrew. Running “synfigstudio” results in following abort:

(synfigstudio:28544): GLib-GObject-CRITICAL **: Object class gtkmm__CustomObject_N6studio15ValueBase_EntryE doesn’t implement property ‘editing-canceled’ from interface ‘GtkCellEditable’
synfigstudio(28544,0x7fff75a52960) malloc: *** error for object 0x10a0c1680: pointer being freed was not allocated
*** set a breakpoint in malloc_error_break to debug
Abort trap: 6

During the installation, I also got this warning message, but don’t know whether it is related to the crash:

Warning: m4 macros were installed to “share/aclocal”.
Homebrew does not append “/usr/local/share/aclocal”
to “/usr/share/aclocal/dirlist”. If an autoconf script you use
requires these m4 macros, you’ll need to add this path manually.

System: OS X 10.7.3 with current Homebrew & Xcode

I have managed to install & run the .dmg (posted elsewhere here) on my other system, but would like to compare stability etc. and whether there are advantages to one or the other.

I am looking forward to diving into synfig (as soon as I can get it running properly).

Thank you!

Tried installng using macports on my other machine, can’t make it work (after a lot of fussing around with installing macports itself, the synfig install seems to abort at the final step with an error). Tried using the app from the .dmg, which crashes after a couple of clicks around the interface. So at the moment I don’t seem to be able to get synfig running at all, under OS X 10.7.3. Any advice? Thanks.

The buildng of synfigstudio with MacPorts fails because of this bug -
We hope to get it fixed in the next release. Until then you can try to compile following instructions by Ulrik: