[Mac OS] Cannot import objects

I am brand new to Synfig. I am trying to start a file and want to import an image I created elsewhere that has been saved as a PNG to my desktop. But every time I try to import I get this message. “Cannot read contents of desktop” I actually get the same message trying to go anywhere. Did I miss something?

Screen Shot 2020-09-20 at 4.00.25 PM

I really need help on this. I have started to drag the images into the file which is a workaround for the import function. But I can’t save any of my work due to the exact same message comes up.

Sorry, I should say I’m on a MAC using 10.15.6 and the latest version of Synfig. Just dowloaded yesterday.

I have the same Catalina 10.15.6 version in a VirtualBox, Synfig 1.3.16.
No problem of access to the desktop, read/write ok
Did you give Synfig permissions of “Full Access to the disk” in Preferences/Security & Privacy/Privacy ?

Thanks for answering, I appreciate the help. I had not given it full disc permission so went back and did that. However it made no difference. Still get the message. I should say that I was able to save something by going to the “home” tab - but only on that tab, nowhere else. And still couldn’t import anything. Also, now it seems that when I try to open that file saved under “home” it is empty. I am going to try and download the whole thing again on my desktop and see what happens.

Hi again. Well I downloaded it onto my desktop but with the same error message as above. I am not sure what I am doing wrong. I did create a test and was able to save it to desktop by highlighting “home” and “desktop”, then save. Without double clicking on desktop. And it saved it to my desktop. However when I try to go out and then open it up again I cannot access desktop. I double click on the desktop and the same message comes up as always. “Could not read…” as in image above. Thanks

Could you check the version number?

Version is 1.2.2

Could you try version 1.3.16 (aka current development version)

The newer version seems to be working fine. Thanks so much for the help.