Linux Binaries for Development version of 0.64.0

I’ve packaged the linbux binaries for the development status of the 0.64.0 release.
The version includes:

New terminology. Say goodbye to the “ducks”. New icons.
New Cairo render engine. On screen render for non raster primitives is faster. It still experimental and some layers doesn’t work. Please use carefully.
New Plugins system by external python script. It allows to manipulate the sif file at your desire.
Some other pretty features and bug fixing.

Download here: … -binaries/
and choose one of the packages that fits your architecture with the proper date (20130401)

Please submit bugs here:

and update your translation language here:


[size=150]EDIT: The packages won’t work for earlier distributions than Ubuntu 12.10. You need to have Cairo >=1.12.0 installed in your system.
I’m working to fix that.[/size]

Should i open one for this issue ?

How libcairo2 1.12 will be linked in 0.64 ?
actually it is provide by quantal 12.10 (ubuntu speaking), or wheezy (debian testing) …


Is there some source code as well? I would like to try building in OSX

Cheers / Ulrik

I haven’t had time to provide a tarball to just configure && make install. You need to fetch the code from the repository, master branch, and proceed as usual.

Remember to change the build instructions with the comment above from d.j.a.y.

I don’t think we should be worried about that. We don’t use cairo text but pango over cairo to render the text layer. In any case the bug should be opened to the Cairo bug tracker, right?

It is possible to link those libraries because the packages we provide aren’t created in the same building environment than the host machine it is compiled. The build scripts for package creation enable a chroot environment and does all the work inside it.

Only the distributions that have newest Cairo versions (>=1.12.0) could create its own packages without troubles or workarounds. This happens all the time when new features are developed :wink:

Alternatives to 1.12.0:

  1. Modify the code with compiler directives to do not compile the Cairo render if the Cairo =>1.12.0 is not present. It means that you can have the other features but not the Cairo render. Currently there is one directive to compile a abort call when you compile with Cairo < 1.12.0. That directive will be removed since I’ve added 1.12.0 dependence in configuration time.
  2. Modify the code to replace the non existing functions in Cairo < 1.12.0 with the operations that so the same. I’m using the following from 1.12:
    cairo_pattern_create_mesh () and derivatives (for conical gradient)
    cairo_surface_create_similar_image () (this is to be able to render the content of the Group layer into a similar image surface. Remember that I need to keep compatibility with any future target like pdf or svg so I can’t assume that the original target is always a image surface)
    cairo_surface_map_to_image () and its counterpart (for direct access to pixel values in raster layers)


Thanks, I managed to build it with the modifications d.j.a.y. mentioned :slight_smile:

Running on Ubuntu 12.10. I keep getting these error messages while installing. It “isn’t” installing.

(Reading database ... (Reading database ... 5% (Reading database ... 10% (Reading database ... 15% (Reading database ... 20% (Reading database ... 25% (Reading database ... 30% (Reading database ... 35% (Reading database ... 40% (Reading database ... 45% (Reading database ... 50% (Reading database ... 55% (Reading database ... 60% (Reading database ... 65% (Reading database ... 70% (Reading database ... 75% (Reading database ... 80% (Reading database ... 85% (Reading database ... 90% (Reading database ... 95% (Reading database ... 100% (Reading database ... 248815 files and directories currently installed.) Preparing to replace synfigstudio 0.63.05-1 (using .../synfigstudio_0.63.05-20130401.master.8_i386.deb) ... Unpacking replacement synfigstudio ... dpkg: error processing /home/cyan/Downloads/synfigstudio_0.63.05-20130401.master.8_i386.deb (--install): trying to overwrite '/usr/bin/synfig', which is also in package synfig 0.63.05-1ubuntu1 dpkg-deb (subprocess): decompressing archive member: internal gzip write error: Broken pipe dpkg-deb: error: subprocess <decompress> returned error exit status 2 Processing triggers for shared-mime-info ... Unknown media type in type 'all/all' Unknown media type in type 'all/allfiles' Unknown media type in type 'uri/mms' Unknown media type in type 'uri/mmst' Unknown media type in type 'uri/mmsu' Unknown media type in type 'uri/pnm' Unknown media type in type 'uri/rtspt' Unknown media type in type 'uri/rtspu' Processing triggers for bamfdaemon ... Rebuilding /usr/share/applications/bamf.index... Processing triggers for desktop-file-utils ... Processing triggers for gnome-menus ... Processing triggers for hicolor-icon-theme ... Errors were encountered while processing: /home/cyan/Downloads/synfigstudio_0.63.05-20130401.master.8_i386.deb

Look at your systems path, here is the answer : synfig does’nt actually support CMYK !

Or maybe … did you try to uninstall previous package ?
I do not need in my case… but … cause of that line :

dpkg: error processing /home/cyan/Downloads/synfigstudio_0.63.05-20130401.master.8_i386.deb (--install): trying to overwrite '/usr/bin/synfig', which is also in package synfig 0.63.05-1ubuntu1


Uninstalled the previous, and now it works. Thanks! :slight_smile:

EDIT: Holy bowls, it’s fast! Quite an improvement!

Unfortunately, it frequently crashes on me. :frowning: Usually in heavier scenes from previous projects.

Bug! (Thought I’d mention here itself)

Try making a scene (I haven’t tried one “without” a raster file in the background) with a few (or many) vectors. Switch on “Low Res” mode, perhaps with setting 8. Zoom in as much as you can.

Ta da! Crash~

Just thought I’d point it out here. For some reason, the crash is rare when the Low Res is off, but frequent when it’s on.

EDIT: Okay, it also freezes and crashes sometimes in non-Low mode…

Please confirm that the bug doesn’t happen with normal render (non Cairo). If so, open a issue tracker.

Well, it’s never happened with the non-Cairo renderer before. I’ve so far rendered plenty of scenes for my main project with them.

Quite fresh compiled one
Switch hight -> low res in cairo mode ON (on fresh new z character template) cause direct & quite systematic crash for me.
Switch hight -> low res in cairo mode OFF (on fresh new z character template) do not test a lot but do not remember crash.

Tsu : nice to see you able reporting fresh new bug :wink:

Another bug: Previewing in Cairo mode gives incomplete picture (some elements missing, such as Raster imports, some legs and arms, etc.). But I think you folks know that already…

EDIT: Okay, so “Previewing” with Cairo switched on also causes crashes apparently…

Anything to help the toolkit progress. :slight_smile:

Thanks for you both reporting bugs!
I’ve fixed several bugs lately so I’ll try to reproduce this new one with the latest version.
I’ll try to create new binaries packages this weekend and allow you to continue finding bugs.

Fixed in master branch.