Lastest Morevna project synfig problem


#1

Have Ubuntu Lucid 32 bit.Downloaded the July first version 2012 .
[]Right clicked on the Canvas
[
]Select Plugins-Simple skeleton.
[]After this operation cannot be undone box and cicking yes a loading screen appeared and synfig shutdown
[
]While writing this it worked tried to add 2 stickmans shutdown.
[*]Never worked again.

Why?


#2

You have to take in consideration that this is a testing feature that Konstantin made for his production pipeline. Before it could be included in the stable branch it needs to be tested on different platforms and make it stable.
Luckily I have an old machine with Ubuntu Lucid installed and I see the same problem.

Possibly the old Ubuntu version plus the new changes on Fedora 17 files structure (where the debian packages are made converted from a rpm using alien) makes some internal libraries to crash.
It is needed to download the latest version from morevna branch, compile it on debug mode and run under a debugger to understand what’s happening.

It is more than probable the it won’t happen until close stages next to the new release, that is not planned yet. I don’t promise to have a release soon meanwhile I’m working on Cairo render migration. Maybe someone else can have time to debug this crash.

-G


#3

How do I do it.


#4

Hi, John!
Thank you for reporting. We have posted updated packages that should fix the issue. Please grab them from software page - morevnaproject.org/packages/
K.