Keyframes not changing

Hello, I’m a newbie at this. I’m trying to animate a logo loader and I’ve already sketched the flow with circles turning into cylinders and new circles joining in at later times.

The problem I’m having is that after adding new circles in later keyframes, it’s showing in the earlier keyframes as well, almost as if that’s the original state.

The only animation i have been able to do is moving a circle from one location to another.

How do i solve this, I’ve searched for a solution so much and I’m super frustrated and confused.

What you need to animate as well is the their transparency through the alpha channel in their property. This is how you do it.
Selecting the circle, in the earlier frames, go to properties and change the transparency to 0. If may be they are to be visible at frame 30, go to frame 30 and change transparency to 1. etc

Thank you so much Tim, that was super helpful.

Now I’m stuck with trying to create a rectangle with curved edges (like a cylinder) out of a circle.

The animation starts from a circle and gradually becomes a rectangle with curved edges.

I’ve read a couple of threads in the forum and i see the best way is to create a spline circle with 8 vertex and then manipulate as i go.

The issue now is that i don’t know how to create a perfect circle with the spline tool… the circles I’m creating are imperfect.

There was also something about horizontal guidelines. I feel so lost

Please kindly help or advice.

Each of the shapes have those properties, select the circle and disable the solid circle but enable the spline circle

I selected the circle and disabled the solid circle. However, the circle created has only 2 vertex and can only move in a specific upward or backward way.

my goal is to create a circle that can become a rectangle in the later stages of the animation.

here’s the guide I saw somewhere else in the forum, but I can’t implement it.

Somewhere one that panel where you disable some properties, scrolling down gives other properties where the number of vertices can be increased

Hello there, I could try helping you a bit as well, hope you guys don’t mind :slightly_smiling_face: :wave:

before you start drawing the circle, make sure to set the ‘spline points’ to 8.
The option to do so can be found over here.
it says 4 right there (or in your case it might be 2), change it to 8 instead

As fo the ‘solid circle’,if you don’t need it you can disable it before drawing, just click on the icon (the full circle one) until it’s not greyed anymore. (but disabling/deleting it works too)

Woaah! That worked!

Thanks you so much. If i need more help i’ll be sure to ask.

1 Like

Ayyyy, you’re welcome! :smile:

Yeah sure, please ask if you need a bit more help, I’ll try to help along if I can~

Great! :slight_smile:

Please mark a post as solution to your first question, to help other people that find your question to easily know the answer :slight_smile: