Importing PNG: size incorrect.

Hi.

In my testing of Synfig (0.64, Debian Testing version), I’ve seen an annoying bug.

When I import a PNG file (I don’t know if this happen with other formats, too) the imported file if 0,98 scaled with to the real canvas.

So, I have to add a scale-layer with -0,98. This could not be too much word, but when you mix layers it becomes hard.

It would be great that the PNG size load correct.

I’ve seen that the scaled is not ever the same 0,98. It depend of the size of the PNG.

Please un-check out: Toolbox->File->Setup->Misc->Scale New imported images to fit Canvas option and then they will be imported with its own size.

-G

Great!

Thanks, Genete. The check must be checked (I had it un-checked).

Be careful when it is checked. It might scale up (with the corresponding loose of resolution) any image that is smaller than the canvas size.

Also consider this when working with images:

  1. They should have at last the same resolution than the wanted output resolution.
  2. Huge images eat a lot of memory.
  3. If you cut the images and crop the empty space around, the check box option of scale the new imported images to fit canvas won’t be your friend.

-G

Yeah, I understand.

Could be possible to move that global option to a local option to the imported image? Maybe in the image property could be that checkbox.

Because, what is the problem to load a PNG in the original size? It’s a code problem?

In fact it is easier to import it with its original size. But in any case in both cases is simple.
-G