Importing a character with skeleton doesn't work


I have been trying to import a character with Skeleton but it doesn’t work. If I do any change to the skeleton during anymation, the changes are not reflected. Then, when trying to open the file again it gives me an error message. This is what I’m trying to do:

  1. I have a pilot.sifz file with my character and his skeleton
  2. I open a new file and import the character from pilot.sifz.
  3. I copy and paste the character. Then I delete the imported file
  4. I animate the character.

If pilot.sifz is not open, synfig will ask me to open it. If I close and open the animated file, synfig gives me a lot of “Wrong data in node <bone_valuenode>” error messages.

Any idea how can I fix this?


I can confirm this bug! I hope it’ll be fixed in the next release.
I figured out that when you copy and paste some layer with skeleton, Synfig misses the id refer of that skeleton and the saved file is corrupt!
You can:

  • [ONLY FOR EXPERT USERS] Open the .sifz file with a text editor and try to restore correct id following the line number mentioned in the error message (like the example below)

  • OR you can open “pilot.sifz”, save them with a new name and you can work with this new file safely! :slight_smile:

For the developers: this problem shows up also when you export a canvas with bones!

Which version do you use?
If it is 1.0.2…
Well known problem and as far as I know solved already in dev builds…
(See my signature)

As far as my experience goes with the current dev builds on Windows the problem with importing rigged characters with skeletons still occur. I am planning free rigged Synfig characters for a long time now, but as long as they can’t be freely imported into scenes for reuse, it does not make sense to spend that much work on characters that nobody is able the import. The only work around I use for myself is either import the characters unrigged and rig them over and over again each time you use them or rig them using the group transformation widget, but that is not the most user friendly method to rig a character. The add skeleton plugin does not work on my current dev build. That also could be a future import problem solver. Sorting out the problems with the import and export of rigged characters using bones and skeletons should be VERY high on the next dev list. Hint, hint… :mrgreen:

I use the last stable version (1.0.2) and, in my personal experience, I can import a Synfig animation with bones. This bug occurs only when I copy and paste some layers with bones or export a canvas with bones (for example i want to create an animation reusable and independent).
Now, my hint is to save with a new name the animation and eliminate all the layers you don’t need, (instead on copy and paste or export).

Thanks all for your replies.

Yes, this is the exact situation I have. When importing from another file and then copying and pasting the character. I started using the hint in this thread (renaming the file) But it would be good to be able to import characters because I usually like to create a character file in different .sifz files.

I’m using 1.0.2


I have done some experimenting and I managed to import two characters with skeleton into a new scene using the plug-in system. Both skeletons seemed to function after importing.

Hello there,

I imported layers to new sifz document and get these errors:

Unable to load “C:\Users\Desktop\Synfig working folder\Sugar_scene_06_v01.sifz”:

  • C:\Users\Desktop\Synfig working folder\Sugar_scene_06_v01.sifz:<bone_valuenode>:65535: error: Unexpected element <bone_valuenode>
  • C:\Users\Desktop\Synfig working folder\Sugar_scene_06_v01.sifz:<bone_valuenode>:65535: error: Bad data in <bone_valuenode>
  • C:\Users\Desktop\Synfig working folder\Sugar_scene_06_v01.sifz:<bone_valuenode>:65535: error: Parse of ‘bone’ failed

There are like 10 more of them.

I tried to delete bone tags with their information in notepad but i´m really noob in coding so i want to ask you if there is a way how to repair it especialy if these bones aren´t in synfig anymore because i deleted them in original document before i copy them.

Thank you very much.

I have the same issue in 1.3.12.

I can’t copy a character who has bones. When i re-open the animation, I got an error of Wrong data in node <bone_valuenode>…

Can you help me?