Imported svg(exported .sif in inkscape) color

Hello,
I have two issue, first one is when I import ‘oval.svg’(which created in inkscape and I upload here:
oval
) on Synfig, I can’t see the path. I found this issue is already known, so I exported as sif for importing on synfig.
Now Second one is when I import this ‘oval.sif(
oval.sif (6.2 KB)
)’ on synfig, I can see the path now, but the color is not what I excpect… If it is also an known issue and there is some solution, could you explain me, please?

  1. Open or import ‘oval.sif’ (I saved in inkscape as synfig animation format) in Synfig.
  2. I can see the color changed. It looks like changed opacity value, so I checked opacity and alpha value, but there were no problem.
    The color what I expected:

    The result on synfig:

Using version
Inkscape: 1.2.1
Synfig: 1.4.2
fedora 36

Thank you.

Canvas → Properties → Gamma correction → set red, blue and green to 1
This will restore the same colors you see in Inkscape
Synfig sets gamma correction to 2.2 for older .sif versions because it used to be the default

2 Likes

Hello coz, thank you for the reply.
I checked the path as you said, and I found the value of red,blue and green are already set 1. :confused:

I think when I save sif file in Inkscape, it saved as older version sif file. Do you know how can I save as new version sif file?

Thank you…!

I think you should do the opposite and set it to 2.2 from 1.

1 Like

Hi @veermetri05 , Thank you for reply!
I tried it, and it didn’t work.
I tried it again with an another file, which had already imported svg(it imported as correct color but missed some shape), and on this file, I imported sif(it imported as wrong color but nothing missed shape). And I tried set it to 2.2 form 1. The result : svg color changed wrong color and sif has no change…

I checked out the file you provided above, that is

It’s gamma values are set to 2.2, and you need to change it to 1.

But, you said

This is because you have not opened the oval.sif file, but created a new Synfig file and imported the oval.sif within this file (Synfig Animation 3), that’s why you are seeing the gamma values as 1 (which are of new file, i.e. Synfig Animation 3). Whenever you create a new file the gamma values will be 1. But when you export from Inkscape your gamma values are 2.2, which you will have to change to 1.

The result was that way because you have ‘imported’ the file. Importing in Synfig isn’t the same as just importing SVG or images, that occurs in other programs. In Synfig, the import happens with the canvas. So the canvas properties of oval.sif are not affected when you update the canvas properties of new file (Synfig Animation 3). So oval.sif still has 2.2 gamma values while the ‘Synfig Animation 3.sif’ gamma values are 1 by default which you changed to 2.2 gave you different colors.

To solve most of your problems: don’t import, just open the file

You are trying to import sif file. But I don’t understand the reason to do so.
If you just want your SVG created with Inkscape to be available in Synfig, just save it as .sif from Inkscape and then open(,not import) that file.

Here’s some steps to follow:

  1. Create all your graphics in Inkscape
  2. Select everything on Canvas and Convert everything to Path (Ctrl + Shift + C), this will give all shapes
  3. Set proper document page dimensions in Inkscape, which will become Canvas size
  4. Organize content properly in Layers (Objects and Layers option).
  5. Go to File → Save As → change option to .sif file
  6. Now just open the .sif file.
  7. If Gamma values are messed up fix them (changing to 1 from 2.2 or vice versa)
  8. Start animating your animations

Importing feature if only useful if you want to break up your main animation in different files, or re-use animation already creating within other file. One other thing to do than importing is, to open both the files and copy paste which layers you want from one file to another.
Hope it clears the understanding, and you may properly begin to animate.

You have done a good job, explaining your problem properly, but missed on some details :sweat_smile:.

3 Likes

Hello again, @veermetri05 !
I opened it directly and now I can change the value and see the correct result.
I got the solution and some good tips!
Thank you very much! :smiley:

And next time, I’ll make better reports :blush:
Thanks again and have a good day!