Imported image files are invisible

I’m following this tutorial: which i remember doing a long time ago with no problems. This time, however, i downloaded the .zip file provided with all the images needed and when i import them to synfig, they appear to be invisible. The layer appears, i can select it and a box appears, but the image itself doesn’t show.
Does anyone have any clue as to how i can fix this?

oh… i had the blend method set to ‘alpha over’. BOY do i feel stupid.

here get the same “silly” issue some times :mrgreen:

I have a same problem, except those alpha-over settings

I have set “Composite” in any possible place, but images appears only in layer window and when they are selected, here are ducks and rectangle only.

I have 0.64.3 (64bit) synfig and ubuntu 12.04 64Bit

Interesting is, that if I open sfiz which was made last year at another machine it looks intact (everything is there include images)

Share the sample file could help