how to render??

Hi, i’m new to Synfig. In fact I’m just trying this software. I’ve tried to do some animation in synfig for a few times which is in 5 second only. I render it to .wmv video and it’s working but the last one is 15s, when i try rendering it, it doesn’t work until now. So, I try rendering them into a series of .png files and try to follow the steps as shown in But well, I never use the command prompt before and when I typed in the line "ffmpeg -r 24 -i bbscene1.%04d.png -f flv test.wmv, I got this:

‘ffmpeg’ is not recognized as an internal or external, operable program or batch file.

What exactly I need to do? I’m using Windows 7 and please be gentle because I never use the command prompt. any help will be appreciated!

Why? What’s not working in the case of 15 seconds?
I’ve used Synfig Studio 0.63.00 in Windows 7 and I can use the ffmpeg target option from the render dialogue.

Anyway, if you need to use the command line you need to cd to the bin folder where ffmpeg is:

cd C:\Program Files\Synfig\bin

or use the full path when calling ffmpeg:

C:\Program Files\Synfig\bin\ffmpeg.exe

Alternatively you can go to:
Control Panel->System and Security->System->Advanced System Settings->Environment Variables
Then there, add a new User environment variable:
Variable Name: PATH
Variable Value: C:\Program Files\Synfig\bin
(last back slash is important)
Then ‘synfig.exe’, ‘synfigstudio.exe’ and ‘ffmpeg.exe’ will be available form anywhere in the command prompt.

Btw, welcome to the forums vick7!

My bad, last night was a mess! I didn’t cd to the bin folder and I never use this kind of technique before (enter a command line).

The 15 sec issue is that, I render the finished product directly into .wmv not .png first and combined them together. I notice this problem when I try rendering the other animation I made which last only 5s and it worked (directly to .wmv not .png first). But when I make the new animation (the 15s) and render it directly to .wmv, it doesn’t work. I don’t know what’s the problem but since I know how to use the command line now, I guess I’ll just stop finding the answer.

Anyway, thanks for the help! I think I’ll spend more time with synfig now! :slight_smile: