How to make non-smooth tangents?

Hi everyone.
So I created a shape and then use Transform tool to modify it.
I Noticed that tangent lines are always parallel and equal to make vertexes smooth.
I try to make them unequal, but can’t figure out how.
Tried to google it, this is what I got:

  • You can also right click on a “Vertex” handle or a “Tangent” handle and it will provide a context menu:
  • For “Tangent” handles: “Split Tangent’s Angle” and “Split Tangent’s Radius” will split the “Tangent” so that you can independently modify the arch of an end point of a Bézier curve. On the opposite, “Merge Tangent’s Angle” and “Merge Tangent’s Radius” will merge the independent “Tangents” so that you can align the arches of the end points of two connecting Bézier curves.

I don’t have any of these in context menu once I click tangents or vertexes.

Another tip said to press Shift before moving tangent. I tries press Shift before, after, simultaneously, but it just moves tangents horizontally/vertically, but they are still equal+parallel.

What Synfig Studio version are you using?
What OS?
I just tried Synfig versions 1.0.2, 1.2.2, 1.4.4 and 1.5.1 (on Linux) and all of them has the context menu working for vertices and tangents.

In canvas window right click on vertex you want to split and you will have “Split tangent’s angle”

Windows 10 x64, Synfig studio 1.4.4.

This is what I get when I right click on a vertex:

Indeed strange. I tried both Synfig Studio 1.4.4 for Windows and thy both work. (and, yes, there were two releases…)

However, there is another way you can split it:

  1. Click on vertex or tangent handle to select it;
  2. Look at Parameters Panel;
  3. The correspondent vertex/tangent will be selected there too;
  4. (double?)Click on Radius Split or Angle Split to enable it
  5. You can move your tangents now

This works, thanks!

But the problem is, if I have dozens of vector it takes so much time to find one I need it barely usable.

Is it possible to assign keyboard shortcut for this Angle Split and Radius Split?

And also, where can I find this other Synfig Studio 1.4.4 for Windows? I only found this:

Actually, I tried investigate a bit, and here is what I found.

I have 6 layers (3 shapes and 3 outlines). For 4 layers this “Split Tangents” option actually works, but for 2 layers it doesn’t and I still don’t understand why.

Perhaps you can see my project file to check what might be the problem?

The layers that doesn’t work for splitting tangents are hair_back_shape and hair_back_outline.

Here is the file

The file is not available.

Hmmmm…, I don’t know what exactly cause that, but there might be something that you can try…

Try right clicking on the affected vertex(es) and/or tangent(s), then convert them to ‘Composite’, which is basically their default parameter (or whatever you might call it).

(!!) though keep in mind that this method might gonna delete some of the waypoints that you have created (in case you have any, of course).

Edit: Nevermind, I just re-read your comments again. And I’m starting to think that the thing I just mentioned might not work…
The reason being that while you can’t split the “glitchy” tangents via right-click menu, it seems that it is still possible to do so from the ‘Parameters’ panel. This nullifies my assumption completely (where I thought the points got converted to another type by accident)…

Sure you can still give it a go, But please don’t expect much… ._.v

1 Like

Wow, it actually worked, after I clicked Convert > Composite that split tangent option appeared and I didn’t lost any waypoints.

Thank you very much!


Do you know what converter it was using?

Ayyyyy, that’s great to hear, you’re welcome!! :smile:

At first I thought that was the case as well. But turns out it was alot simpler.

Take a look again at the screenshot that was posted.

After editing my initial response (saying that it may not work), I noticed that the context menu has one unusual option; ‘Interpolation’. So I tried to find that menu by doing conversions and stuff, and found out that the tangents/vertexes were actually ‘Disconnected’, most likely by accident.

(and only after that whole discovery thing, I finally realized that the ‘Disconnect’ option was missing as well… oops ^^;)

1 Like