how to keep aspect ratio when resize


I’m a fresh user of synfig.

for the moment I only have one problem : each time I try to resize an imported image or an object I can’t keep the aspect ratio.
The lock proportion option is enable in the tool panel and I’ve tried alt, ctrl and shift keys too.
I’m sure I missed something but I don’t know what.

I’m running 0.63.03 version on arch 64bits.


When I import vectors into Synfig, I often use a Zoom layer to resize them rather than resizing them on the stage.

(New Layer > Transform > Zoom)

However I use the Scale tool on the toolbox to make sure I scale things on the stage correctly. There is a “Lock Aspect Ratio” check box that appears in the Tool Options than ensures that aspect ratio is respected.

EDIT: Make sure you select all the ducks using Ctrl-A first.

Hi Dave 3,

thank you for your reply.

The Zoom layer way works great.

The “Lock Aspect Ratio” check box is enabled in the tool options when I use the scale tool but it doesn’t work for me.

Be sure that all the ducks are selected (highlighted).