Help with shadow puppet/skeleton animation

Hi there… I’m utterly new to Synfig and to animation (I vaguely remember playing with 2D animation on the Atari ST back in early 90s but I don’t think that counts for much anymore :wink: ). My interest is in traditional folktales and storytelling and I’m experimenting with the idea of creating shadow puppet style animations of traditional folktales, but I’m falling at the first hurdle. I’m trying to create a shadow puppet mermaid by using various shapes and linking them with a skeleton but am running into a problem where, when I try and move one of the bones, the associated object flies off as if pivoting around a completely different point entirely. I’ve uploaded a screencast to youtube so you can see what I mean

Each object (hair, head, human torso, fish body, fish tail) was created in Inkscape and imported and as far as I can tell I have followed the wiki tutorial instructions (when I follow them with simple shapes created in Synfig it works fine). I would be grateful for any pointers as to where I may be going wrong? I am using Synfig Studio 1.0.2

Da’s Vector pro on the Atari TT was the best vector animation program ever!! :smiley:
Did you by chance copy the group folder containing the hair from another version of the drawing or from another file? When you copy group folders in and/or from other projects it sometimes happens that the pivot points get screwed when you bind them to bones. For instance suppose I draw a shape, group it and call it upperarm. Draw another shape, group that too and call it lowerarm. Then I group both groups and call the new group armleft. Now I also need a right arm, but I am lazy so I just copy the armleft group and rename it armright. No problems so far. When I rig the contents of the armright group to a skeleton there is much chance that the pivot points are screwed. To solve it I never make copies of groups inside a drawing when I know I have to bind them to a skeleton. Instead I copy the outline and regional splines and regroup them afterwards. You can try to rebind the hair again to the same skeleton or you can ctrl-x every spline of the hair out of its group, delete the empty group then rebind the splines to the skeleton and regroup them again. I also suggest that you make your drawings in Synfig, because sometimes the conversion from Inkscape to Synfig does not always stick. A good tip is also to save an unrigged version of your character so that you can start over, because deleting existing bones is not always the safest way to go.
Can you attach the sif file? Maybe there is a way to fix your file.


Thanks for the help and advice :slight_smile: I think I just imported them directly having created the svg files in Inkscape, but I’ve deleted and retried so many methods I can no longer be certain

The reason I used Inkscape was that I had a jpg mermaid which I converted to splines and then broke down into the four separate parts. I’ve attached the resulting sif file (before adding any bones)

I’ve since tried an alternative approach, which is to break the body parts as pngs which has worked fine… I don’t yet know if that will scale as well as I want though. I’ll try and get my head round vector image editing in Synfig Studio. I’m also working my way through the Edemy tutorials so I will continue experimenting.
svgmermaid.sifz (21.3 KB)

Could not fix your file. Problem also existed after I rigged the original file. Even after I cleaned all the folders and or copied the splines out of their existing folders into new ones. Tried rigging without folders at all but that gave the same problem. Could be a bug or something went wrong with the conversion from inkscape. I quickly retraced the mermaid in Synfig and afterwards rigged it and then it worked.

svgmermaidrigged.sifz (8.29 KB)

Thanks for your time and help! :slight_smile: So certainly for the time being it looks like my artwork needs to be created in Synfig… ah well, that’s the excuse I need for a drawing tablet :smiley: I’ll keep on at this treating it as a bug until I can find a solution (it would be great to confidently be able to use Inkscape), but follow your suggestion for progressing my animation


I have been having trouble with skeletons. I’m new to Synfig and am working my way through the tutorials. Everything was going to plan until I got to the skeletons. I’m posting my query as a reply to this thread because the first of my issues looks like the same problem, but for a different reason.

I downloaded the stable version of the software yesterday, so that makes it version 1.2.1, I think. I’m using Windows 10 and a Wacom Intuos graphics tablet.

The first issue was with the tutorial for making an arm move (see my attached picture). When I move the skeleton, the various parts of the arm jump to odd locations. As far as I can tell, this is for a different reason than the original poster - I drew all the components from scratch in synfig, and as far as I can remember, didn’t copy any elements. I’ve tried various things I’ve gleaned from different tutorials etc, like grouping each arm part as a sub-group of the part above, and moving the position of the skeleton in the hierarchy, but nothing seems to help.

I think when I first linked the hand to the skeleton, I may have forgotten to ctrlA to select all the handles, but I deleted the whole skeleton layer and tried again, being more careful, and still had the same problem. So I decided to leave it for the time being and move on to the next tutorial…

The second issue was with the tutorial morphing a puppet. Again, I drew the puppet from scratch in synfig, and it’s all one piece with no outline, as per the tutorial. This time when I move bones, some of the handles seem to get left behind, so my puppet is pulled into odd shapes. I have repeated the process and made sure I’d correctly selected all the handles, but it keeps happening.

Thank you for your help,

Best attach both scenes to a new post so someone can have a look at them. If your sif files contain pixel images then also attach the image(s).

Hello again,

Here are the two files that I referred to.

bonemorph.sifz (4.9 KB)
arm.sifz (10.7 KB)

]I use skeleton deformation that is easier to use.

arm.sifz (10.4 KB)

bonemorph.sifz (5.59 KB)

Well, those files work, but I don’t understand why that would work and my original files do not.

What is the difference between the two ways of moving a skeleton?

I think if I could get my first way to work, I would prefer that. It seems more intuitive. For example, I don’t like the way that the skeleton deformation layer makes a limb fatter when you stretch it to make it longer.

I fixed your arm.
The origin (the green dot) of your upperarm, lowerarm where the same, namely 0,0. But the origin of your hand was not. After setting the origin of the hand region layer and outline layer to 0,0, the skeleton worked. When you have to move a drawing then it is best to select all its points (region and outline) and then drag it into its place other then to use the green dot.
Also fixed your bonemorph. I reset your origin of the drawing to 0,0 and rearranged your skeleton and linked selected points to the proper bones to make it work. (select the points you want to bind and then ctrl select the bone you want to points to bind to and rightclick on the bone and select link to bone)

armforum.sifz (9.44 KB)

bonemorphforum.sifz (4.3 KB)

skeleton deformation works in way of inheritance. you can use several “skeleton deformation” one by each part of the character

You can best use a normal skeleton on vector drawings and skeleton deformation on pixel based drawings. If your vector drawing contains textures then you can combine both skeleton and skeleton deformation. But even if you play with the subdivisions it will be difficult to get a perfect bend in an arm when using skeleton deformation

It exists some form to darse when a vector this linked to a bone specify?

Thanks very much for your help! Got them working now.