Help with getting started.

Hi, I downloaded Synfig 0.63.02 and have been reading the online wiki to get started.

I have a Fujitsu 4210 TabletPC with onboard Intel graphics and I’m running Windows 7 home premium. 2GB Ram, 38GB hard disk.

The first time I tried Synfig, the tablet pen wouldn’t pick up or draw in the Canvas window. I read the thread here and tried changing the input devices settings on the toolbox file menu. At first I managed to get the mode tab to change from “disabled” to window but the calibration was off. So I changed it to “screen” and it was accurate and I could draw in the canvass window. I also managed to change the pressure tab from none to 1.

A day later when I had time to try the software again, the settings seemed back to original and I couldn’t draw. I tried again with the input devices tab but the pressure tab just wouldn’t change and it kept going back to none.

So, right now I can’t draw. Inkscape works fine however one large file I was working on before I installed Synfig was suddenly corrupted and neither Inkscape nor Illustrator would open it any more. I don’t use GIMP as I really don’t like it so is there any other way I can check what isn’t happening?

I don’t have the option to test my wacom graphire on Windows but I would do this:

  1. Remove or rename the C:\Documents and Settings\your_user_name\Synfig folder. This will allow to start from fresh settings.
  2. Plug the tablet first, before start any application.
  3. Test Inkscape. Close it
  4. Start Synfig Studio and follow the thread’s recipe you mentioned.

Good luck!
-G

The tablet is built into the screen - the option that comes up in the input panel is “WACOM Tablet ISD stylus” - however I tried the tips and Inkscape works but the input panel tab isn’t consistent. I tried changing the settings and for a while the tabs remained at default setting then eventually I was able to change the x and y as well as pressure and save - however when I closed Synfig and tried again it was back to no input.

Do I need to delete the settings folder every time I use Synfig?

I don’t know if it would help but can you do this?

  1. Remove or delete the synfig folder to get a fresh settings.
  2. Start Synfig Studio and close it. Make a copy of the settings file inside the synfig folder.
  3. Start Synfig Studio again and follow the recipe to make the tablet work.
  4. If success, then close Synfig Studio and copy again the new saved settings file.

Paste here both files (before and after configure) and maybe I can see why the settings are not being saved or loaded.
-G

I’ll do that next - however I read your instructions and had another go (on the off chance) and same as before. Next, I went back into the input devices tab and this time changed the “Wacom Tablet ISD Stylus” tab to Wacom Tablet Erasor" - that stayed as changed so I closed the panel and tried drawing…

and it drew! So I closed Synfig down and tried it again - no changing anything and it drew again. Anyhow, I’ll track down the folders and attach them as you asked.

Thanks for your help and time so far! :slight_smile:

OK. I deleted the last user Synfig folder to return to original state and I now have two copies of the settings file - I tried attaching it but the forum software won’t allow the extension (error: The extension is not allowed.)

I’ve zipped the two files up and that has attached. Settings 01 is the one that now works and settings original is the one that doesn’t let me draw.

One thing I noticed though was I could draw but the info / history palette didn’t record the actions. I noticed that when the pen tool has worked in the past I could see a record of actions as it recorded location, interaction and tool use. (if that makes sense)
settings original.zip (1.81 KB)

It is normal.
In the original one none of the devices are enabled.
mode=disabled
But in the 01 settings you have the core pointer mode set to screen and the stylus set to screen too.
That makes sense.

Can you undo a draw operation made with the stylus?
Please do this:

  1. Draw a circle
  2. Using the Draw tool draw a stroke
  3. Show me a screen shot of the History Panel
    Thanks!
    -G

No, the undo buttons don’t work with the stylus. I can draw a circle and undo that though.

Sure, attached.

That’s not the stylus. That’s the Sketch tool. It is doesn’t produce animatable stuff, just a sketch to save/load or make visible or invisible or clean.
The Stylus (sensible press pressure device input) works only with the Draw Tool (the icon on the ToolBox is a blue ink bottle with a black cap).
-G

:laughing: My bad. The sketch tool wasn’t working before either. None of the tools when I first started were working.

Thanks! I guess I can now make my way out of page 01 on the Wiki. Thanks for your time.