Help Rendering


Went through the tutorials and this program seems awesome!! I was able to achieve the simple animations I needed for a video presentation. HOWEVER, I’m down to the final steps - rendering - I’ve followed two tutorials I found online, can’t seem to get any of the .avi / mpg / mpeg / mp4 / ogv or anything to create a file. .avi using Windows 7 seems the best - I get no errors in the command window, and the application takes around 21 seconds to render (shows that render has completed), doesn’t crash (as some options) - I’m using as many defaults as possible - but no matter what I cannot get a file to create.

I need to be able to use this file in my nonlinear editor.

Help me understand what I am doing wrong??

Love the program and happy to make a donation if I can get this to work!


Forgot to mention, I’m on Windows 7 64-bit. Using the latest alpha version available on the site.

I’ll keep fiddling, did some forum reading and found a few suggestions. This is a helpful place!

If I try to render an .avi file, I get “unable to find a suitable output format for C:\Program Files…”

.mpg, mp4 and mpeg will hang or crash the app.

From reading, it look like ffmpeg commands aren’t responding as Synfig expects.

I have my paths set up correctly so both ffmpeg and synfigstudio.exe are accessible from anywhere. i wonder if there’s an older version of ffmpeg.exe that works appropriately in Windows?

From my experience Synfig can be a little clumsy in Windows environment.

You can try rendering with the following settings:

  1. Do not render to “C:\Program files”, you may not have the right permissions. Instead, create a temp folder somewhere else (e.g. “C:\Temp”) and render there.
  2. In render dialog set parameters manually as:
    a. Filename: C:\Temp\Animation.avi
    b. Target: ffmpeg
    c. Parameters: Windows Media Video 2, wmv2, 2000
    Other settings adjust as you wish.

That worked!! Thank you!

This is strange, I had created a few different directories as I’d read about permissions issues… but only c:\Temp seems to work.

Windows 7 and a .avi file extension work. The animation I made is smooth!

I’m super happy about this because I’ve been learning “other programs” and none of them were as intuitive as Synfig.

Also my background is a Unix/Linux admin but my home Linux machine is down for repairs. As soon as I get it back online in the next week or two, I’m going to run Synfig on it.

Thanks for the help!


Hi Scott,
we are as happy as you for your success.

Please quote that on social networks because Synfig has the curse of being un-intuitive

The solution presented above does not seem to work on my system using Windows 7 and the latest alpha release of Synfig. I can’t render any avi files, only stills in the form of for instance png’s. Also get the same error. It’s not the end of the world since I usually edit the png files in another program, but it would be nice to be able to render a quick avi to check things, because the preview is not always reliable.

Those settings should work, I tested it on my Windows 7 machine. I assume there’s some simple mistake on your side.

Check out my render dialog in the attached file, maybe you’re missing something…

Nope. I have exactly the same settings and it does not render any avi files.

edit: It works now. synfig animation.avi did not render, but synfiganimation.avi did. Spaces in naming files are apparently a nono. That is a bit strange cos the default name that Synfig gives to a file when you try to render it does contain a space. Anyway, it works with all the codecs, so Yay! :smiley:

Hell, you’re right! And I thought it’s a problem with permissions…

Created bug report: … issues/749