Help? Not sure if a Text Problem or a Rendering Problem

Hello,

I’m generally finding the text tool confusing (seems there is only 1 font, and “weight” does nothing?) but my real problem happens when I render. I have an animation with several different files that correspond to each scene, and despite rendering all of the files with the same settings, I feel like different ones have slightly different qualities.

However, this is extremely obvious whenever there is text. In some files, the text is rendered as a blur. In other files the text is readable.
Does anyone know why this inconsistency is happening, and what I can do to fix it? I’m sure it will get better if I just make the text into a png file and import it, but that seems slightly tedious and I’d rather learn something.

I’ve attached 2 PNG images from different files (one was C&P’d from the other) to show you the difference in the text on the person’s red shirt. I don’t know of any difference between those images except that they are in different files. I’m running a developmental version of SynFig 1.1.11 built on Aug 3, 2016, if that makes a difference.

I suspect the problem is with rendering, rather than with the text tool, because if you look at things like the person’s arm, in one version the outline looks slightly more jagged.

Thanks!


Hey there,

It’s most definitely the render settings. Are you totally sure it’s identical? Check this:

  1. Do you render your work in loseless format? H.264 (loseless).
  2. Are rendering settings identical? Quality, bitrate, Anti-Alising, etc.
  3. Are there any color filters? Like ‘New layer -> Filter Colors -> Color correct’ maybe?
  4. Canvas settings are identical too? Image size, image span, etc.

About text layer, yeah, it’s buggy under Windows, though I heard about some tricks like placing the font file directly in Synfig directory to make it work. There was a thread about it somewhere…

  1. Yes, I render as lossless PNG sequences
  2. They are completely identical, unless I’m missing something. I adjust the quality and anti-aliasing, and leave the rest alone.
  3. There are no color filters, but I have other layers like solid color layers.
  4. As far as I can tell, all the settings for the two (actually 13, but I’m randomly picking two that render differently) files are the same.

My render settings (for all) are as follows:

File name–>name.png
Target–>auto
Quality–>1
Anti-aliasing–>1
Width–>1920 XResolution–>72
Height–>1080 YResolution–>72
Image Area:
-4 2.25
4 -2.25
Image Span: 9.1788

As far as I am aware, there are no color filters. But I also have the text render problem even in the main program before I hit the render button. For instance, take a look at this screenshot below. The rest of the picture is rendering in smooth lines, but the text is not. In a different file, the text appears fine in the working view.

This is especially confusing to me because I created the character in one file, and then pasted him into all the other files. The original file is one of the files in which the text does not appear clear.

Would attaching .sif files help?

Thanks!
Capture.PNG

Wait a second… The text is simply wrong. Like there’s a character set problem or some sort. Well, as I said before, the ‘Text’ layer is buggy and I can tell you another issue with it where it won’t display any other locales rather than English.

Check out this article about text layer in Synfig: morevnaproject.org/2016/09/08/s … le-synfig/
As suggested there, you can try specifying a full font path in ‘Font Family’ of ‘Text’ layer properties.

Another recommendation would be to make your text in Inkscape and then export it to Synfig as vector graphics. This should work perfectly and you’ll be also able to choose different font in a more obvious way.

But…why would it be wrong in the ORIGINAL, but then fixed in one of the copies? The text is in English, btw. It says “Chess. IS. A Sport.”

So, the solution is to just accept it as an unsolvable bug and import the text graphics from elsewhere?

Well, it’s an acceptable workaround, but not a solution, yes.

Did you try the link I provided? Anyway, now that’s the rendering is probably not an issue, I can give you some more directions:

  1. Try the link above.
  2. Install the latest development version (1.1.12 if I remember correctly).
  3. Disable Cobra engine in development version. It should be somewhere in ‘Edit -> Preferences…’.
  4. Install the stable version (1.0.2) and try to open your project. It might not work at all if you use new features, but worth a try.
  5. If nothing helps, post your problem file here. Maybe someone will take it from there.

Yeah, I did look at the link. That seems to be about changing the font though? I’ll definitely keep that in mind for next time, but for this animation the default font is fine. I didn’t try using the last official Synfig build because I need Papagayo.

I actually figured out what the problem was–or rather, I figured out how to fix it. In all the files where the text is readable, I have a “warp” layer over the text (although it’s off, so I didn’t think it mattered). By adding that warp layer on top of my other files, and turning it off, the text is now readable.

Suuuuuper weird, but at least I’m not going crazy because there WAS a difference between the two files. I just didn’t think layers that were unchecked mattered, and I have no idea why adding a distortion layer would un-blur text.

Anyway, thanks for you help! I’m curious why the text would be blurry or not based on an “off” layer, but for now my problem is solved.