[Help] Icon name for enable/disable layer rendering

I found that in latest builds, there are 2 layer option entries without icon:

  • Enable layer rendering
  • Disable layer rendering

I surfed the code but could not find any reference to the names assigned to these commands. Could anybody tell me them so that I could design them?


@ice0 @rodolforg no clue?

In Blender, there are :

  • :eye: “Hide Viewport”
  • :camera: “Hide Render”

Why not use

  • :movie_camera: that is used for File/Preview
  • :clapper: that is used for File/Render

associated to a :no_entry_sign: (or :x: :no_entry: :stop_sign:)?

I like the idea… btw I would need the name of the icon files

Hi, guys!

It looks like these commands don’t have icon names assigned. So you can choose any, and I will add them.

  • layer_rendering_enable_icon / layer_rendering_disable_icon and layer_viewport_enable_icon / layer_viewport_disable_icon
  • rendering_layer_enable_icon / rendering_layer_disable_icon and viewport_layer_enable_icon / viewport_layer_disable_icon
  • rendering_enable_icon / rendering_disable_icon and viewport_enable_icon / viewport_disable_icon
  • enable_rendering_icon / disable_rendering_icon and enable_viewport_icon / disable_viewport_icon
  • Other… (propose)
0 voters

We could just start with the most voted option and just with “rendering” mode as the “viewport” one is not developed yet.

1 Like

Agree. This is closest to the current naming scheme.

1 Like

Hi @ice0
Let’s do the following then:

  • layer_rendering_enable_icon
  • layer_rendering_disable_icon
  • layer_viewport_enable_icon
  • layer_viewport_disable_icon

I’ll design them all but I know the only ones that will work by now will be the “rendering” ones. This way the icons are ready for the future.

I’ll add them to feat: new icons by pgilfernandez · Pull Request #3167 · synfig/synfig · GitHub in which I’m adding a good bunch of other new icons, OK?


1 Like