Graphics tablet unresponsive to Synfig

tablet

#1

I do apologize if this isn’t the thing I should be posting in this section as I’m rather new to the product and forum.
I’ve been having a lot of trouble getting my wacom bamboo tablet to work with Synfig.
I’m using a Windows machine and the tablet works fine with GIMP and other programs but when I try to sketch on Synfig nothing comes out.
I’ve tried almost every drawing option but nothing comes out onto the canves.
Are there any specific drivers I need or is it just something I cant use?


Huion tablet not working
Synfig with Wacom not working, or is it?
Synfig with Wacom not working, or is it?
Weird object generation with Wacom bamboo
#2

Hi DasSwift,
I don’t have a windows machine with a wacom tablet attached but I could give you some hints to try to make it work:
First, go to your C:/Documents and Settings/Your user name/Synfig/settings and rename it. This will ensure that any old “bad” settings is removed and replaced by new ones.
Second, with the tablet plulggen on, open Synfig Studio again and go to your toolbox and open the Device Settings Dialog. If it recognizes the device it must be listed there. Usually there are more than one devide listed on the Device Dialog. Select all them one by one and be sure that all they are Disabled. Then one by one Enable it and test the Draw Tool using your tablet. Usually only one of them would work as expected (with pen pressure). Once found, leave it as Enabled and the rest disabled.

Good luck.
-G


#3

Here’s my recipe for getting the tablet kick started w/Synfig under win7.

  1. I have to open Synfig by double clicking on the application icon with the pen. If I use the mouse, then Synfig seems to ignore the tablet. (“No input device found”)
  2. Select File, Input Devices. Hopefully Wacom tablet pressure stylus will be listed (or something similar). Just selecting that with the pen seems to kick start the program to recognize Pressure, X tilt & Y tilt (otherwise, I only have 2 inputs listed - X & Y)
  3. Change the screen mode from Screen mode to window, save, then change it back to screen mode and save again. Close the Input device dialog.
  4. Select a tool in the dialog, like the ink tool or curve tool, and you should see it working. If not, repeat steps 2 & 3 again.

Hope this helps for you. I wish I knew why it was so picky. :frowning:


Gaomon Tablet not working with Synfig
#4

Thankyou very much, both of you. I’ve got it working now, which is great ^^
Excited to try some animations with Synfig


#5

This advise worked for me with my Vistablen Pen Pad. The only problem is that in the freehand draw mode the pencil icon is offset down and to the left of there the actual drawing takes place. But at least I got the tablet and pen to respond in synfig. Which was something that it was NOT doing for about two months since I purchased it.


#6

I work 10 + hours a day on my XP-Pen Artist22E graphics tablet amazon.com/dp/B01M9EURM1 . I’ve been using graphics tablets for over 8 years. I absolutely need one because i paint/draw for a living and these days people need things done fast soo digital is the way to go.

I’ve been using XP-Pen tablets for all this time. I wouldnt recommend ANY other brand but wacom for graphics tablets. They are the best. I currently use a Medium size XP-Pen Artist22E .

For just scribbling notes and doing minor photo touch ups I would recommend either a Small XP-Pen Star05 ( which cost about 70$ Canadian) more or less.


#7

I m using Huion 640p and Windows 8.1…But, the program isn’t responding… I tried changing the Input Device Settings by changing other options to Disabled and just Huion stylus to Screen… Then just after clicking on the screen, the program closes.