Gif Animation Problem


#1

Hi all, this is my first post and thanks in advance for any help you can give.

I’m a new user, and for fun I created a very simple GIF animation in Synfig, a cartoon hand that waves.

When I rendered the GIF animation it worked perfectly well on my computer. But when I posted it on Twitter, it’s completely ruined by having a fanning effect (I’m sure there’s a technical term for it, but I am new!). Here’s a link to my twitter post so you can see the problem:

twitter.com/funuple/status/874742039451242499

Can anyone tell me what I’ve done wrong here?


#2

Hi!
Try rendering the file with Macick++ as a target and .gif as the extension of the filename.
Greetz!


#3

Thanks for your reply Darkspace. Unfortunately I’ve tried that and have the same problem :frowning:

The frustrating thing is that it looks fine on my computer, it’s only when I upload it to Twitter that the problem appears, meaning I can’t predict the issue.


#4

Also can anyone tell me what the technical term for is for the problem? Might help me find help on google.


#5

Hey there,

First of all, gif is kinda an obsolete format and should be avoided at all costs. Unfortunately, it’s pretty much a standard for simple web animations… 2017 year and we still don’t have a better format - ‘mng’ is awful and ‘apng’ is still unpopular.

Technical term for your problem is probably ‘transparent color’. Someone doesn’t correctly handle it. Either Synfig doesn’t export it right or Twitter can’t process it.

I can think of two possible solutions:

  1. Add background color to your animation (in Synfig: new layer -> geometry -> Solid Color) and set it to a desired color (white, I guess). Render as gif and reupload to Twitter.
  2. Export your animation to ‘png’ target, then convert it to gif using some random online service. Just search in Internet something like this: “png to gif animation”.

#6

Hi!
Posted a gif made with Synfig 1.3.2 windows 10. Rendered target auto name extension gif. Seem ok to me on twitter.
Greetz!
https://twitter.com/DibaKartoens/status/876785688263503873


#7

Thanks guys, I will give it a try at the weekend. Darkspace that looks great! I’m using development version 1.3.3, perhaps that’s the problem. If I can’t get it to work I’ll revert to 1.3.2 and see if that helps.

I’ll have a play soon and report back, as this might be something useful for others.


#8

Nope, had a play tonight and exactly the same issues.

Interesting thing is that it looks absolutely fine when I preview it, and even when you see the quick preview before you upload it in twitter it looks fine. It’s only at the actual point it is live on twitter do you see the problem. Arrgghhhhhhhhhhhhhhhhhh…

twitter.com/funuple

I’ve tried changing the target and the quality, doesn’t make any difference. I’ll try a previous stable version and see if that helps. I’ll get there!


#9

Hi!
Of all the tests I did only one came out bad as you can see here: https://twitter.com/DibaKartoens/status/877027983302721536. It’s the only one that does not use a background. So the solution could be as Svarov mentioned to use a background, whether it is a colored shape or a solid color background layer. That is something I use standard in every scene. You could also attach your scene file so to see if we get a different result or not after rendering.
Greetz!


#10

It worked!

twitter.com/funuple/status/877578721955368965

Thanks so much for your help. The fact you had the same issue with a transparent background is good, so it wasn’t anything I did. For the record, I used the default settings (auto). All I changed was the filename extension to gif.

Thanks again.


#11

Oh and a thanks to Svarov too, you spotted the error straight away - adding a background. Thanks to both of you.


#12

i use:
https://raw.githubusercontent.com/thevangelist/FFMPEG-gif-script-for-bash/master/gifenc.sh

4232.cf/2017/06/21/gif-animation-scene-6/