everytime I close canvas the whole synfig close too

hi everyone
my problem is when I close canvas that I just worked on and saved,it has some error window pops up said “synfigstudio.exe has encounter the problem we sorry to an inconvenient…” I recognize that window message from windows system, then I click “clickhere” to see more information and it shows me somekind of has a problem with module name “libsynfig-0.dll”, then I click ok button the synfig close down. it happen everytime I close canvas after saved, if I close canvas with no save there’s nothing wrong with synfig, what’s wrong with it, how can I fix this problem, please give me some help.

pmu :frowning:

Hi Guest,
would you like to tell us what’s your operating system and the synfig and synfigstudio version you have installed?

synfig 0.61.08, windows xp pro 2002 servicepack 2, on notebook msi, cpu mobile amd sempron 3600+ 2.01 Ghz, ram 896 Mb

pmu :frowning:

Also, I’m curious as to whether it’s related to any particular layer you’re saving in the canvas? Do you see this on all canvases, no matter what content? Or only on specific files you’re trying to save?
Maybe you could post your sif or sifz file to help debug?


yes, it happen every canvas I did drawing. I done my demo for 20 scenes, it almost get me crazy! and more information, now I just noted when I open my scene’s canvas, do nothing, then close with no save, synfig also close too.

pmu :frowning:

I attached sifz file for you may be usable

02.sifz (8.85 KB)

I’m not able to reproduce the bug. I’ve loaded the file (cool drawings BTW) and made visible other layers and after close said “no” and synfig didn’t closed. I’m linux user and I believe that nothing is wrong with the file itself. It should be some other problem.

more information, I tries to reintall 2-3 times(all gtk and synfig), but still got same problem.

pmu :neutral_face:

Well, I’m sad to say that I can’t reproduce it. I’m sad, because I think I have seen something similar in the past, especially when I opened up multiple canvases and closed the ‘not the most recently opened’ one.

On the plus side, your animation looks great :slight_smile:


I was wondering, does this problem also occur when you start a new drawing/animation (i.e., with a fresh system)? Or does it only occur when you first load the file that you sent us?


PS: One difference is that we don’t have the jpeg background file. Have you deleted some layers (such as the background layer) and see what happens (as an experiment?).

I seem to have found a recipe for a crash that is related:

  • Start in some directory, in my case: Desktop
  • Create a PNG file, in my case: Desktop\data.png
  • Start Synfig Studio, in my case: Desktop
  • Import the PNG in the root canvas
  • Save the root canvas, in my case: Desktop\Synfig Animation 1.sifz
  • Close the root canvas (succeeds)
  • Close Synfig Studio
  • Start Synfig Studio again, in my case: Desktop
  • Open the root canvas, in my case: Desktop\Synfig Animation 1.sifz
  • Close the newly opened window --> Crash

This is on WIndows XP with a downloaded Synfig Studio, installed accoording to the video (i.e., with TaskAssign running). When I delete the file data.png before loading Synfig Animation 1.sifz, the crash does not occur.


I think that it’s was exactly happen to my case, Gerco. and regarding to jpg.file layer that you mentioned, I found that involved with the problem either. in a few days ago I tried to thought out what’s wrong with the program. did some experimented then I found. every single canvas I worked on, I made as a scene, I had to imported layout image file(jpg.)to scene. some scene(canvas) had 7-8 layout images file, for traced the bline. I tried to deleted all imported images layers in scene, then click canvas close button for ask for save, click yes(if I press Ctrl+s and close canvas, it’s crash), canvas closed but synfig still open! after repeated do this again and again, the result was the same, synfig still open. OK I finally threw the heavy thing out off my head. now I knew the way to avoid that crash and working fine I don’t know may be the program has somekind of memory or data management problem, but I know some day this bug will be fix. I still using synfig
create animation with pleasure. (such a great patential program) for now I like to thank all of you who tried to help me along the way. and thank you for admired my work.

pmu :smiley: