error on Ubuntu Intrepid

I am trying to build synfigstudio on Intrepid, (since the one on the repository crashes with a segmentation fault), but I receive the following error.
make[2]: [128x128/synfig_icon.png] Error 1 (ignored)
synfig -q synfig_icon.sif -o 128x128/synfig_icon.png --time 0 -w 128 -h 128
synfig: symbol lookup error: synfig: undefined symbol: _ZN6synfig11open_canvasERKSsRSs
make[2]: *** [128x128/synfig_icon.png] Error 127
make[2]: Leaving directory /util/synfigstudio-0.61.09-r2171/images' make[1]: *** [all-recursive] Error 1 make[1]: Leaving directory/util/synfigstudio-0.61.09-r2171’
make: *** [all] Error 2

What am I missing?


First you should uninstall the packages from the repositories. When you do the synfigstudio build it uses the synfig binary to create the icons of the GUI. So if the current installed synfig (old version from the repository) is called instead the one you have build from the sources, maybe it fails during installing due to unsupported canvases versions of old version.

Also please check if you have built etl, synfig and synfigstudio (in this order) and if you have all the development libraries installed.

Check out this post I’ve made in other thread to see if it helps you.


Otherwise read carefully the build instructions and follow them step by step. We are dealing to make synfig latest release to be able to be build on Ubuntu Intrepid. And are modifying the build instructions accordingly.


Thanks for the help. Finally compiled and running. Before I read your instructions, I had not disabled the line # 622, and synfig core had compiled just fine. The only problem was that I needed to do sudo ldconfig before compiling the studio.

After compiling the studio successfully, on running synfigstudio complained of missing Then I ran ldconfig as a user, and it worked. I guess the cached user profile did not get updated on sudo ldconfig.

synfigstudio: error while loading shared libraries: cannot open shared object file: No such file or directory

It runs successfully now, but I yet have to use it.